multi server its not coreckt

Discussion in 'Installation/Configuration' started by senkron24, Mar 26, 2013.

  1. senkron24

    senkron24 New Member

    i have install step to step in this how to bud this ist not coreckt

    http://www.howtoforge.com/multiserv...servers-on-debian-squeeze-with-ispconfig-3-p6

    or its better says with one ispconifg he duit

    i do it with 3.5.1

    i have evrey think installed only what not work its the last step
    server service
    i do thad what thare writet

    Click on System > Server services > web.example.tld and disable all checkboxes except of the Webserver and Fileserver checkbox and click on Save.


    and than second time he write

    Click on System > Server services > mail.example.tld and disable all checkboxes except of the Mailserver checkbox and click on Save.

    bud i see only my web.xxxx not mail.xxx
    how can i add my db ns1 ns2 mail all this in

    server services
    i hope any can answer
    b.r
    senkron24
     
  2. darinpeterson

    darinpeterson HowtoForge Supporter

    Hi senkron24,

    Did you add all of your servers to the master server's MySQL database like this:

    Code:
    CREATE USER 'root'@'192.168.0.106' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.106' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'192.168.0.107' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.107' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'192.168.0.108' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.108' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'192.168.0.109' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.0.109' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'mail.example.tld' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'mail.example.tld' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'db.example.tld' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'db.example.tld' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'ns1.example.tld' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'ns1.example.tld' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'ns2.example.tld' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'ns2.example.tld' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    Also, when you installed each server, did you install ISPConfig 3 pointing each slave to the master?

    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]: <-- y
    MySQL master server hostname []: <-- web.example.tld
    MySQL master server root username [root]: <-- root
    MySQL master server root password []: <-- Enter the root password of the master server here

    Darin
     
  3. senkron24

    senkron24 New Member

    sorry for my late answer

    yes of course i have duit step by step

    and i do master and slave
    master its who have a ispconfig with panel
    and other slave servers have a not panel only instal slave with ispconfig

    bud i think thare its mistake in any steps bud i have not found

    its very nice this to use with 5 server

    bud only for you know
    i install all my server in esxi server in one pc and i sure the right ip adress
    otherway i cannot coneckt to the slave servers etc ..

    i hope any can check this its right step to step

    b.r
    senkron24


     
  4. senkron24

    senkron24 New Member

    i have dalte all server and install new and make all step

    bud now i have main server ok and client ok
    bud i have problem with db ns1 ns2 when i will coneckt this to the main server its give me fail thad say

    msql conket server error

    i use same pass for root etc way its work for my mail server and not for db and ns1 ns2

    bud i will try again

    and write result here

    b.r
     
  5. senkron24

    senkron24 New Member

    now its all rady

    its fault
    CREATE USER 'root'@'ns1.example.tld' IDENTIFIED BY 'myrootpassword';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'ns1.example.tld' IDENTIFIED BY 'myrootpassword' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;

    i dont know whats in the first foult

    bu ok now the sever its rady

    i will test more and post result

    thanks for all
    b.r

    senkron24
     
  6. darinpeterson

    darinpeterson HowtoForge Supporter

    Hi senkron24,

    Here is some information that might help more...

    Please make sure that you are performing these commands on your mysql database, and NOT the ISPConfig database. You can do this by installing your primary server first, login to phpmyadmin, click on the mysql database and run the following for every server except your primary server.

    Say your primary server is on 192.168.1.151 (and say this is the mail server running the ISPConfig Control panel, which is mail.myserver.com).

    Say you have three other servers:

    192.168.1.152 web.myserver.com
    192.168.1.153 db.myserver.com
    192.168.1.154 ns.myserver.com


    Entry for web.myserver.com
    Code:
    CREATE USER 'root'@'192.168.1.152' IDENTIFIED BY 'PA$$WORD';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.1.152' IDENTIFIED BY 'PA$$WORD' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'web.myserver.com' IDENTIFIED BY 'PA$$WORD';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'web.myserver.com' IDENTIFIED BY 'PA$$WORD' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    Entry for db.myserver.com
    Code:
    CREATE USER 'root'@'192.168.1.153' IDENTIFIED BY 'PA$$WORD1';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.1.153' IDENTIFIED BY 'PA$$WORD1' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'db.myserver.com' IDENTIFIED BY 'PA$$WORD1';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'db.myserver.com' IDENTIFIED BY 'PA$$WORD1' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    Entry for ns.server.com
    Code:
    CREATE USER 'root'@'192.168.1.154' IDENTIFIED BY 'PA$$WORD2';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'192.168.1.154' IDENTIFIED BY 'PA$$WORD2' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    CREATE USER 'root'@'ns.myserver.com' IDENTIFIED BY 'PA$$WORD1';
    GRANT ALL PRIVILEGES ON * . * TO 'root'@'ns.myserver.com' IDENTIFIED BY 'PA$$WORD1' WITH GRANT OPTION MAX_QUERIES_PER_HOUR 0 MAX_CONNECTIONS_PER_HOUR 0 MAX_UPDATES_PER_HOUR 0 MAX_USER_CONNECTIONS 0 ;
    
    Now that you have created the user database records for your other servers, go ahead and install them and run IPSConfig installation on them. Make sure when you are asked if you want to join a multi-server setup you say "y" and the name of the multi-server setup is "mail.myserver.com".

    I hope this helps...

    Good luck,
    Darin
     

Share This Page