Multi php versions Ubuntu 16.04

Discussion in 'Installation/Configuration' started by Poliman, May 24, 2017.

  1. Poliman

    Poliman Member

    I would like to setup under ISPConfig 3.1.3 newest version of php 5.6. I have Ubuntu Server 16.04. Command
    Code:
    apt-get build-dep php5
    gives error:
    Code:
    E: Unable to find a source package for php5
    Is it possible to avoid this?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try:

    apt-get build-dep php7.0
     
  3. concept21

    concept21 Member

    Try:
    apt-get build-dep php5.6 :cool:
     
  4. Poliman

    Poliman Member

    Code:
    apt-get build-dep php7.0 
    working but after execute
    Code:
    ./configure --prefix=/opt/php-5.6.30 --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --enable-exif --enable-bcmath --with-mhash --enable-zip --with-pcre-regex --with-mysql --with-pdo-mysql --with-mysqli --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl --with-fpm-user=www-data --with-fpm-group=www-data --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-imap --with-imap-ssl --with-kerberos --with-gettext --with-xmlrpc --with-xsl --enable-opcache --enable-fpm
    I got error
    Code:
    configure: error: Cannot find imap library (libc-client.a). Please check your c-client installation.
    
    Are these two the problem generating error (whole configure command which I paste works on ubuntu 14.04) ->
    Code:
    --with-imap --with-imap-ssl


    Concept21 - your answer gives error like for php5. ;)
     
  5. Poliman

    Poliman Member

    I resolved this problem by adding symbolic link:
    Code:
    ln -s /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/libc-client.a
    and before it I did what Till said. I have php 5.6.30 under Ubuntu Server 16.04 LTS. ;)
     
  6. Poliman

    Poliman Member

    I have a question. I have php 5.6.30 under Ubuntu 16.04 but I am not sure it works like it should. Problem is that I haven't in Response Headers line X-powered by: php some_version. I turn on php5.6.30 in website settings in ISP. I found all php.ini files:
    Code:
    /opt/php-5.6.30/lib/php.ini
    /etc/php/7.0/fpm/php.ini
    /etc/php/7.0/apache2/php.ini
    /etc/php/7.0/cgi/php.ini
    /etc/php/7.0/cli/php.ini
    In each I changed expose_php from Off to On. Nothing happens after restart apache and php5.6.30.fpm and php7-fpm service for php7 php.ini. Where can be the problem? I can post some screenshots or whatever will be needed.
     
  7. ahrasis

    ahrasis Active Member

    Sounds like somethings are missing in your current php 5.6.30 build. If I were you I'd try rebuilding and reinstalling it again.
     
  8. Poliman

    Poliman Member

    I could but how to do it on Ubuntu 16.04 if I did install process based on tutorials:
    https://www.howtoforge.com/how-to-u...fpm-and-fastcgi-with-ispconfig-3-ubuntu-12.10
    https://www.howtoforge.com/how-to-b...e-and-apcu-for-ispconfig-3-on-debian-7-wheezy

    Here is the output of ps aux | grep php:
    Code:
    root      1519  0.0  0.1 304280 12808 ?        Ss   Jun07   0:56 php-fpm: master process (/opt/php-5.6.30/etc/php-fpm.conf)
    www-data  1521  0.0  0.1 304268  8816 ?        S    Jun07   0:00 php-fpm: pool www
    www-data  1522  0.0  0.1 304268  8816 ?        S    Jun07   0:00 php-fpm: pool www
    web1      1523  0.0  0.1 304272 10948 ?        S    Jun07   0:00 php-fpm: pool web1
    web1      1524  0.0  0.1 304272 11016 ?        S    Jun07   0:00 php-fpm: pool web1
    ispconf+ 20532  0.0  0.5 462348 41460 ?        Ss   06:25   0:00 /usr/bin/php-cgi -d disable_classes= -d disable_functions= -d magic_quotes_gpc=off -d open_basedir= -d session.save_path=/usr/local/ispconfig/interface/temp
    ispconf+ 20533  0.0  0.2 462772 17240 ?        S    06:25   0:00 /usr/bin/php-cgi -d disable_classes= -d disable_functions= -d magic_quotes_gpc=off -d open_basedir= -d session.save_path=/usr/local/ispconfig/interface/temp
    root     22141  0.0  0.0  12888   932 pts/1    S+   07:04   0:00 grep --color=auto php
    root     27629  0.0  0.6 473944 42340 ?        Ss   Jun19   0:03 php-fpm: master process (/etc/php/7.0/fpm/php-fpm.conf)
    www-data 27632  0.0  0.1 473944 10132 ?        S    Jun19   0:00 php-fpm: pool www
    www-data 27633  0.0  0.1 473944 10132 ?        S    Jun19   0:00 php-fpm: pool www
    
    I checked that ISP uses php.ini from path /etc/php/7.0/cgi. After changing expose_php I need restart apache and stop and then start php7.0-fpm service.

    PS
    Now I am finding https://www.howtoforge.com/tutorial/how-to-install-php-5-6-on-ubuntu-16-04/ which is a little different but all commands from two tutorials above worked well on Ubuntu 16.04. One different is in 3rd point - another place of init file and his another content. At the bottom of header of 3rd point is an information "I will create a systemd unit file to be able to start / stop and restart the PHP-FPM service." but I can start/stop/restart php-fpm service.
    Second thing - in output above are two lines for web1 user - so I suppose it works. I checked one more thing. I setup in Website settings default php (7.0), not this additional. Still I don't see X-Powered By in Chrome console. Finally I disabled php like in attached screen -> https://i.imgur.com/eeoVRFc.png. Nothing happens. Website still works and without php version in headers. So maybe it's not a problem with additional php?

    EDIT
    Site does not use php...
     
    Last edited: Jun 20, 2017

Share This Page