Discussion in 'Installation/Configuration' started by PoleCat, Feb 10, 2008.

  1. PoleCat

    PoleCat New Member

    I'm not sure if anyone else has experienced this, or just me. It has been doing this on the previous verison of ISPconfig aswell, .16. I am currently running .18

    What happens is, when I create a new site and lets say 5 email address under that site. Test it, works fine, i can receive email from the server under the new user i created for that domain. Now the client comes to me and says he wants to send through the server his emails. Now I dont allow that as I can't afford to take the chance and have my server blacklisted incase 1 dumb client sends spam through it. Seeing that I have over 140 active clients with sites on the server having it blacklisted will be disasterous. Anyway, when that happens I set the MX records for that domain to ASP.MX.GOOGLEMAIL.COM and I use Google Apps for just the clients email. (Yes I do this as I have corporate clients and they dont ever use the control panel on ISPC, giving them GoogleApps email with their own domain name, makes them non the wiser.) Ok so I then go to Options and I set mailserver as "External".

    Ok now the client can get his emails from google perfectly and he is very happy. BUT for some reason when his website on ISPC tries to email his own domain name, the mail gets delivered to the Maildir queue locally on the server and goes somewhere on the server that I cant find. The ISPC server does not lookup the MX records and does not send out the email to Google Apps like it should.

    The mail.log file just says (delivered to maildir). Then nothing else.

    Anyone else experienced this?
  2. falko

    falko Super Moderator ISPConfig Developer

    Is the domain name listed in /etc/postfix/local-host-names?
  3. PoleCat

    PoleCat New Member

    Yeah it is.
    If i manually remove the domain from the list and restart postfix then it solves the problem.

    Seems ISPC does not delete the host from the file when setting the ""external email server" option.

    Can you confirm this on error on your side?
  4. jnsc

    jnsc rotaredoM Moderator

    did you also set external mail server for every co-domain?
  5. PoleCat

    PoleCat New Member

    There are no co-domains. If there was, where is the setting for that? I thought "External mailserver" was a global setting for that site.
  6. jnsc

    jnsc rotaredoM Moderator

    usually when you create the co-domain is automatically created.

    Go to Co-Domains select the ip in front of There in the Options field you have Mailserver: Local Mailserver
  7. PoleCat

    PoleCat New Member

    Ahh I see, thats confusing. Having the "external Mailserver" option in two places is a bad design. I think the main Options "external mailserver" should be globally setting all co-domains and the main domain to external. Maybe the developers must look at simplifying this.
  8. jnsc

    jnsc rotaredoM Moderator

    Yes, and No. Because some people want that behaviour. For example If you have the mail for locally, but you have a co-domain for and you want to receive the mail for this domain on an external MailServer.

    It's much more flexible to be able to set this value for every single co-domain. But as usual advanced futures bring also complexity.

Share This Page