msql problems

Discussion in 'Installation/Configuration' started by jbesedic, Feb 6, 2007.

  1. jbesedic

    jbesedic New Member

    I'm now having issues with authenticating with msql

    This is what I'm getting

    Please enter your MySQL user:root
    Please enter your MySQL password:
    ERROR 2003 (HY000): Can't connect to MySQL server on 'www.beefobradys.com' (111)The provided MySQL password is wrong!
    Please enter your MySQL server:


    Is there a way to go back and see what I used for the following MySQL server? user? and password?

    I'm almost certain I used the root as user and my root password for the password.
     
  2. jbesedic

    jbesedic New Member

    I figured it out

    The server was localhost


    Feels good to fix your own mistakes.
     
  3. armitage

    armitage New Member

    So close yet so far

    Help I've got the same problem but it will not except my password

    this is the command I typed after I followed the instructions

    mysqladmin -u root password password

    after my second install I cannot get this to work.

    Help!!

    :d
     
  4. armitage

    armitage New Member

    I triple checked that password this time and I have followed these instructions and tried to install ispconfig 4 times now.

    It's a tragedy to be so close yet to be so bloody dumb I don't why this is not working for me.
     
  5. armitage

    armitage New Member

    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    The provided MySQL password is wrong!
    Please enter your MySQL server:
     
  6. armitage

    armitage New Member

    you have got to be joking...

    just because I used dollar signs in my password it doesn't work

    this is crap

    Quote:
    Originally Posted by dranieri
    I have checked everything and verified my MySQL password and user....it is giving me the same error message....I don't know what else to do.....please help me.


    please post the output of this command to the forum:


    Code:
    netstat -tap | grep mysql
    Does your mySQL password contains any special chars (other than a-z A-Z 0-9 _)?
     
  7. armitage

    armitage New Member

    so now that I've clearly established I'm an idiot for not reading the forums properly can anyone guide me how to fix this without having to re install etch again?

    :d
     
  8. mtuser

    mtuser New Member

    check the right password.
    you'll see
    make sure that you know that password
     
  9. armitage

    armitage New Member

    Hey thanks nice tip.

    I'm giving up on ISPConfig for while, too much time wasted.
     
  10. falko

    falko Super Moderator ISPConfig Developer

    You can set a new password (without special characters) like this:
    Code:
    mysqladmin -u root -p password newpassword
     
  11. armitage

    armitage New Member

    web:~# mysqladmin -u root -p password password
    Enter password:
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'

    this is the error I get when I try that?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that you use the wrong password or your mysql server does not listen on localhost. Please post the output of:

    netstat -tap
     
  13. armitage

    armitage New Member

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:mysql                 *:*                     LISTEN     2103/mysqld
    tcp        0      0 *:sunrpc                *:*                     LISTEN     1783/portmap
    tcp        0      0 *:auth                  *:*                     LISTEN     2276/inetd
    tcp        0      0 *:ftp                   *:*                     LISTEN     2436/proftpd: (acce
    tcp        0      0 *:3445                  *:*                     LISTEN     2405/rpc.statd
    tcp        0      0 web.myserver.com.:domain *:*                     LISTEN     2004/named
    tcp        0      0 localhost.locald:domain *:*                     LISTEN     2004/named
    tcp        0      0 *:smtp                  *:*                     LISTEN     2336/master
    tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     2004/named
    tcp6       0      0 *:imaps                 *:*                     LISTEN     2247/couriertcpd
    tcp6       0      0 *:pop3s                 *:*                     LISTEN     2267/couriertcpd
    tcp6       0      0 *:pop3                  *:*                     LISTEN     2253/couriertcpd
    tcp6       0      0 *:imap2                 *:*                     LISTEN     2231/couriertcpd
    tcp6       0      0 *:www                   *:*                     LISTEN     2468/apache2
    tcp6       0      0 *:domain                *:*                     LISTEN     2004/named
    tcp6       0      0 *:ssh                   *:*                     LISTEN     2365/sshd
    tcp6       0      0 *:smtp                  *:*                     LISTEN     2336/master
    tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     2004/named
    tcp6       0      0 *:https                 *:*                     LISTEN     2468/apache2
    tcp6       0    740 web.myserver.com.au:ssh  ::ffff:192.168.1.2:1775 ESTABLISHED2510/0
    
    :D
     
  14. falko

    falko Super Moderator ISPConfig Developer

    MySQL is running, so I guess you entered a wrong password.
     
  15. armitage

    armitage New Member

    Nope.

    after reinstalling etch several times and twice because of mysql password

    I made sure I didn't. However I do see that mysql doesn't like unusual characters which I guess is my issue IE password = pa$$word.

    Still doesn't tell me how to fix it.

    thanks for the info anyway.

    As I said time to give it a break for a while.
     
  16. armitage

    armitage New Member

    etch install number 5 fixed the issue.

    I tried uninstalling mysql with purge and reinstalling but didn't work.

    thanks Till and Falko.
    :D
     
  17. astra2000

    astra2000 New Member

    same problem here :(


    I reinstall mysql and i just made this:

    mysqladmin -u root -p password mypassword

    and return this error:
    error: 'Access denied for user 'root'@'localhost' (using password: YES)'



    someone knows what i need to do??:confused:
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that you entered the wrong password. To change the password to a new password, you must enter the correct old password when the command prompts for it.
     
  19. astra2000

    astra2000 New Member

    but i dont remember the password :(
     
  20. falko

    falko Super Moderator ISPConfig Developer

Share This Page