Mozilla Thunderbird mail client

Discussion in 'Installation/Configuration' started by kreya, Jun 13, 2007.

  1. kreya

    kreya New Member

    Hi,
    i would like to use Mozilla Thunderbird for sending and receiving mails.
    i am able to send/receive mails using squirrelmail web interface.

    when i tried sending a mail to my yahoo account it says

    sending of message failed
    the message could not be sent because connecting to SMTP server
    server1.mydomain.com failed. the server may be unavailable or is refusing connections. please verify that your SMTP setting is correct and try again.

    SMTP settings
    server name : server1.mydomain.com
    port 25
    username & password
    username : [email protected] : password

    i tried with SSL at port 465 but got the same message. tried with just username but no use.
    same with pop3 port 110 and pop3 SSL port 995
    portforwarding is enabled for ports - 25,110,465,995

    i installed ispconfig using IP instead of domain name cos' the changes with my domain weren't updated . now i am able to ping www.mydomain.com, smtp.mydomain.com, pop3.mydomain.com.

    i use my ISP DNS servers. so didn't make any entries in ispconfig DNS Manager. i want this machine just to be a mail server.

    what should i do to fix this
     
    Last edited: Jun 13, 2007
  2. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Hi

    Username should be somtehing like "webXX_username" where XX should be the assigened number of the site.

    what are your DNS entries?
     
  3. kreya

    kreya New Member

    i changed the login format by removing user prefix in
    management-system config--settings- user prefix --Blank
    i login with my email id without webXX prefix and is working fine.

    i think there's some problem connecting to the server as the error indicates

    sending of message failed
    the message could not be sent because connecting to SMTP server
    server1.mydomain.com failed
    . the server may be unavailable or is refusing connections. please verify that your SMTP setting is correct and try again.
     
  4. Hans

    Hans Moderator ISPConfig Developer

    When you want to send an email with your smtp server, you need to enable "this server needs authentication" within your emailclient.
    This means that you have to enter a loginname/password for sending e-mails.

    If this will not work, please have a look to your /var/log/mail.log file.
    You can read your logfile online with the commands:

    cd /var/log/

    tail -f mail.log

    or:

    tail -f mail.warn

    Quit = CTRL+C
     
    Last edited: Jun 13, 2007
  5. mlz

    mlz New Member

  6. kreya

    kreya New Member

    i reinstalled the machine
    i try to login using web1_user (got that from ispconfig cpanel)

    here's my Mozilla thunderbird setting

    account name work account
    your name myname
    email address [email protected]
    reply to email address [email protected]

    server settings - server type popmail server
    server name server1.mydomain.com
    username web1_user
    port 110

    Outgoing server (SMTP)
    server name server1.mydomain.com
    port 25
    username & password - enabled
    username [email protected]


    i tried with both [email protected] and [email protected] and it asks for a password. but it doesn't authenticate me though the password is correct and iam able to login via squirrel webmail.

    i ran the port scanner in ispconfig tools it shows port 25, 110 are open
     
  7. Hans

    Hans Moderator ISPConfig Developer

    Do you see any errors within your logfiles related to your actions?
    Please have a look within:

    /var/log/mail.log and /var/log/mail.warn
     
  8. kreya

    kreya New Member

    error messages

    fetchmail and saslauthd were not running. turned them on now.
    but even then it keeps asking for password and doesn't authenticate. here's the log details

    Mail.log

    Jun 14 16:33:51 server1 postfix/smtpd[4769]: connect from unknown[192.168.1.254]
    Jun 14 16:33:56 server1 postfix/smtpd[4769]: warning: SASL authentication failure: Password verification failed
    Jun 14 16:33:56 server1 postfix/smtpd[4769]: warning: unknown[192.168.1.254]: SASL PLAIN authentication failed: authentication failure
    Jun 14 16:33:58 server1 postfix/smtpd[4769]: warning: unknown[192.168.1.254]: SASL LOGIN authentication failed: authentication failure
    Jun 14 16:34:03 server1 postfix/smtpd[4769]: disconnect from unknown[192.168.1.254]
    Jun 14 16:34:10 server1 postfix/anvil[4601]: statistics: max connection rate 2/60s for (smtp:209.191.68.137) at Jun 14 16:31:01
    Jun 14 16:34:10 server1 postfix/anvil[4601]: statistics: max connection count 2 for (smtp:209.191.68.137) at Jun 14 16:31:01
    Jun 14 16:34:10 server1 postfix/anvil[4601]: statistics: max cache size 1 at Jun 14 16:24:10


    Mail.warn

    Jun 14 16:33:56 server1 postfix/smtpd[4769]: warning: SASL authentication failure: Password verification failed
    Jun 14 16:33:56 server1 postfix/smtpd[4769]: warning: unknown[192.168.1.254]: SASL PLAIN authentication failed: authentication failure
    Jun 14 16:33:58 server1 postfix/smtpd[4769]: warning: unknown[192.168.1.254]: SASL LOGIN authentication failed: authentication failure


    Mail.log while trying to retrive emails using mail client -POP3

    Jun 14 16:32:35 server1 courierpop3login: Connection, ip=[::ffff:192.168.1.254]
    Jun 14 16:32:53 server1 courierpop3login: Disconnected, ip=[::ffff:192.168.1.254]


    server name : server1.mydomain.com
    login format : both web1_username and [email protected] didn't work

    how can i fix this
     
    Last edited: Jun 14, 2007
  9. mlz

    mlz New Member

    If the server is local to you (on your home network) then this is fine, if not, it can still be an issue, the port scanner only scans the server, not the connection.

    If your server is located at a data center, or remotely away from you, try do this at the command line:

    telnet yourhost.com 25

    change yourhost.com to your domain name. You should see a welcome screen, if you do not, it's pretty likely that port 25 is blocked by your ISP and you need to open up an alternate port. If you plan on having customers, your going to eventually need to do this anyway.
     
  10. kreya

    kreya New Member

    Iam able to send and receive mails using outlook express but not able to send mails in ThunderBird
     
  11. falko

    falko Super Moderator ISPConfig Developer

  12. kreya

    kreya New Member

    yes it's web1_username.
    I removed secure authentication option and now I am able to receive mails in thunderbird on POPs port 995.

    thanks a lot for helping me out.
     

Share This Page