Moving to nginx failing

Discussion in 'Installation/Configuration' started by MetZ, Nov 12, 2011.

  1. MetZ

    MetZ New Member

    Hi..
    I am struggling with ISPconfig latest and moving to nginx.

    I have even tried to completely re-install my server, before installing ispconfig
    http://www.howtoforge.com/perfect-server-ubuntu-11.10-with-nginx-ispconfig-3-p7

    It looks like ISPconfig does not start, I can not find it in my processes list. I tried to do an update on it, and it spits out a couple of error messages:
    Code:
    Configuring Apps vhost
    PHP Warning:  symlink(): No such file or directory in /tmp/ispconfig3_install/install/lib/installer_base.lib.php on line 1515
    Configuring Database
    Configuring Bastille Firewall
    Updating ISPConfig
    PHP Notice:  Undefined property: installer::$ispconfig_interface_installed in /tmp/ispconfig3_install/install/update.php on line 333
    Reconfigure Crontab? (yes,no) [yes]: 
    When doing a fresh-install, some symlink error appeared (I have tried 3-4 times now, almost giving up and going back to apache2).

    Any suggestions? any logs I can check? Try to load ispconfig manually?

    Thanks for any help!
    -Tom

    EDIT:
    After more research on this, I have figured more out. I think it has something to do with nginx. Now I receive a 403 Forbidden message when domain.com:8080
    If I go to domain.com (phpinfo in index.php), the phpinfo display with FPM/FastCGI as server API.
    I have tried to look at the ispconfig.vhost file, but as I am totally new to nginx, I am not sure where to start. it is the default vhost file installed with installer.
    Any suggestions?
     
    Last edited: Nov 13, 2011
  2. falko

    falko Super Moderator

    Is this an Ubuntu 11.10 system? Did you follow the tutorial to the letter?

    What's the output of
    Code:
    ls -la /etc/nginx/sites-available/
    and
    Code:
    ls -la /etc/nginx/sites-enabled/
    ?
     
  3. MetZ

    MetZ New Member

    Hey..

    I decided to go back to apache2 for now on this server.. I will give it another go on a another server later.

    Anyway.. This is a ubuntu 10.04 lucid xen vps.
    sources-list:
    Code:
     deb http://nginx.org/packages/ubuntu/ lucid nginx
     deb-src http://nginx.org/packages/ubuntu/ lucid nginx
    
     deb http://ppa.launchpad.net/brianmercer/php/ubuntu lucid main
     deb-src http://ppa.launchpad.net/brianmercer/php/ubuntu lucid main
     deb http://ppa.launchpad.net/brianmercer/fcgiwrap/ubuntu lucid main
     deb-src http://ppa.launchpad.net/brianmercer/fcgiwrap/ubuntu lucid main
    My server host only offers 10.04 on xen vps/dedicated, So I gave it a honest try to get nginx and ispconfig going on it.

    /etc/nginx/sites-available/ispconfig.vhost + app.vhost I think it was.
    and no sites-enabled dir at all.

    If u have any suggestions, I will give it another go on my other vps when I get the time..

    thanks!
    -Tom
     

Share This Page