Moving server manualy => default php version seem broken for phpmyadmin and roundcube

Discussion in 'Installation/Configuration' started by electronico_nc, Mar 25, 2022.

  1. Hi all,
    Ubuntu 18.04 server standalone (perfect server 18 tutorial)
    ISPConfig 3.2.7p1 (latest)
    This server had all its Apache2 setup messed-up (no GUI)
    Every other services than Apache were running.

    After fighting trying to get Apache2 running, choosen option has been : manul transfer to new server (no way for ISPCopy or migration tool)

    (shorted)
    Installed ISP Perfect server Apache Ubuntu 18 on new server.
    Mixed /etc/passwd (and such files) from old to new server.
    Transfer emails and websites from old to new.
    Transfer dbispconfig database from old to new.
    Adjust values for server in ISPConfig ( server IP, serveur name )
    Launch a resync of everything.
    The bad thing is that I forgot to install additional PHP versions prior to inject dbispconfig database.
    And I deleted and recreated a php7.2 additional version in ISPConfig panel ...

    (state)
    ISPConfig is running OK ( https://server:8080 )
    phpmyadmin doesn't display anything ( https://server:8080/phpmyadmin )
    roundcube doesn't display anything neither ( https://server:8080/webmail )
    phpmyadmin and roundcube were running prior to delete the php7.2 add. version in ISPConfig panel.

    The default php version is no more displayed in drop-down menu for PHP version :
    [​IMG]

    Code:
    MariaDB [dbispconfig1]> select server_php_id, name FROM server_php;
    +---------------+--------+
    | server_php_id | name   |
    +---------------+--------+
    |             5 | php7.4 |
    |             7 | php8.0 |
    |             9 | 7.2    |
    +---------------+--------+
    
    I know it is not a standard situation, and any thoughts are welcome.
    Thanks in advance for your time.

    PS : Another strange thing is the logging format for ispconfig.log : (\r\n are displayed, there is no CR into log)
    Code:
    tail -f /var/log/ispconfig/ispconfig.log
    
    25.03.2022-14:14 - DEBUG [plugins.inc:155] - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.\r\n25.03.2022-14:14 - DEBUG [server:217] - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock\r\n25.03.2022-14:15 - DEBUG [plugins.inc:155] - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.\r\n25.03.2022-14:15 - DEBUG [server:217] - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock\r\n25.03.2022-14:16 - DEBUG [plugins.inc:155] - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.\r\n25.03.2022-14:16 - DEBUG [server:217] - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock\r\n25.03.2022-14:17 - DEBUG [plugins.inc:155] - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.\r\n25.03.2022-14:17 - DEBUG [server:217] - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock\r\n
    PS2 : I had to disable the httpd monitor, else it would restart Apache every minute...
     
    Last edited: Mar 25, 2022
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    phpmyadmin and roundcube do not use the php version settings inside ispconfig; what matters here is what your default php interpreter is for the web server; you probably need to "a2enable php7.x-fpm" and restart apache (I don't know what the correct default is for ubuntu 18, php7.2-fpm?)

    You are running 3.2.8 rather than 3.2.7p1 .. update again and 3.2.8p1 will fix this.
     
    electronico_nc likes this.
  3. Hi,
    update ISPConfig has well fixed the ispconfig.log \r\n thing : thanks !
    php-fpm is well running :
    Code:
    ps ax | grep fpm
     8015 ?        Ss     0:02 php-fpm: master process (/etc/php/7.2/fpm/php-fpm.conf)
     8029 ?        S      0:00 php-fpm: pool www
     8031 ?        S      0:00 php-fpm: pool www
     8077 ?        Ss     0:02 php-fpm: master process (/etc/php/7.4/fpm/php-fpm.conf)
     8093 ?        S      0:00 php-fpm: pool www
     8094 ?        S      0:00 php-fpm: pool www
     8252 ?        Ss     0:02 php-fpm: master process (/etc/php/8.0/fpm/php-fpm.conf)
     8268 ?        S      0:00 php-fpm: pool www
     8270 ?        S      0:00 php-fpm: pool www
     8294 ?        Ss     0:02 php-fpm: master process (/etc/php/8.1/fpm/php-fpm.conf)
     8311 ?        S      0:00 php-fpm: pool www
     8313 ?        S      0:00 php-fpm: pool www
    27723 pts/1    S+     0:00 grep --color=auto fpm
    php-cgi too (urls changed) :
    Code:
    ps ax | grep cgi
    27319 ?        Ss     0:00 /usr/bin/php-cgi -d disable_classes= -d disable_functions= -d magic_quotes_gpc=off -d open_basedir= -d session.save_path=/usr/local/ispconfig/interface/temp
    27321 ?        S      0:00 /usr/bin/php-cgi -d disable_classes= -d disable_functions= -d magic_quotes_gpc=off -d open_basedir= -d session.save_path=/usr/local/ispconfig/interface/temp
    27330 ?        S      0:01 php-cgi8.0 -d open_basedir=/var/www/clients/client121/web225/web:/var/www/clients/client121/web225/private:/var/www/clients/client121/web225/tmp:/var/www/xxx.nc/web:/srv/www/xxx.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client121/web225/tmp -d session.save_path=/var/www/clients/client121/web225/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27340 ?        S      0:01 php-cgi8.0 -d open_basedir=/var/www/clients/client105/web201/web:/var/www/clients/client105/web201/private:/var/www/clients/client105/web201/tmp:/var/www/yyy.nc/web:/srv/www//web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client105/web201/tmp -d session.save_path=/var/www/clients/client105/web201/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27342 ?        S      0:01 php-cgi8.0 -d open_basedir=/var/www/clients/client105/web201/web:/var/www/clients/client105/web201/private:/var/www/clients/client105/web201/tmp:/var/www/yyy.nc/web:/srv/www/yyy.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client105/web201/tmp -d session.save_path=/var/www/clients/client105/web201/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27543 ?        S      0:01 php-cgi7.4 -d open_basedir=/var/www/clients/client109/web207/web:/var/www/clients/client109/web207/private:/var/www/clients/client109/web207/tmp:/var/www/zzz.nc/web:/srv/www/zzz.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client109/web207/tmp -d session.save_path=/var/www/clients/client109/web207/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27544 ?        S      0:01 php-cgi7.4 -d open_basedir=/var/www/clients/client21/web453/web:/var/www/clients/client21/web453/private:/var/www/clients/client21/web453/tmp:/var/www/aaa.nc/web:/srv/www/aaa.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client21/web453/tmp -d session.save_path=/var/www/clients/client21/web453/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27552 ?        S      0:03 php-cgi8.0 -d open_basedir=/var/www/clients/client209/web465/web:/var/www/clients/client209/web465/private:/var/www/clients/client209/web465/tmp:/var/www/bbbb.nc/web:/srv/www/bbbb.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client209/web465/tmp -d session.save_path=/var/www/clients/client209/web465/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27600 ?        S      0:00 php-cgi7.4 -d open_basedir=/var/www/clients/client125/web237/web:/var/www/clients/client125/web237/private:/var/www/clients/client125/web237/tmp:/var/www/ccc.nc/web:/srv/www/ccc.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client125/web237/tmp -d session.save_path=/var/www/clients/client125/web237/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27603 ?        S      0:01 php-cgi8.0 -d open_basedir=/var/www/clients/client137/web297/web:/var/www/clients/client137/web297/private:/var/www/clients/client137/web297/tmp:/var/www/ddd.nc/web:/srv/www/ddd.nc/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom -d upload_tmp_dir=/var/www/clients/client137/web297/tmp -d session.save_path=/var/www/clients/client137/web297/tmp -d sendmail_path=/usr/sbin/sendmail -t -i -f [email protected]
    27612 ?        Ss     0:00 /usr/bin/php-cgi -d disable_classes= -d disable_functions= -d magic_quotes_gpc=off -d open_basedir= -d session.save_path=/usr/local/ispconfig/interface/temp
    27613 ?        S      0:00 /usr/bin/php-cgi -d disable_classes= -d disable_functions= -d magic_quotes_gpc=off -d open_basedir= -d session.save_path=/usr/local/ispconfig/interface/temp
    ...
    php is well setup for 7.2 by default:
    Code:
    update-alternatives --config php
    There are 4 choices for the alternative php (providing /usr/bin/php).
    
      Selection    Path             Priority   Status
    ------------------------------------------------------------
      0            /usr/bin/php8.1   81        auto mode
    * 1            /usr/bin/php7.2   72        manual mode
      2            /usr/bin/php7.4   74        manual mode
      3            /usr/bin/php8.0   80        manual mode
      4            /usr/bin/php8.1   81        manual mode
    Code:
    update-alternatives --config php-cgi
    There are 4 choices for the alternative php-cgi (providing /usr/bin/php-cgi).
    
      Selection    Path                 Priority   Status
    ------------------------------------------------------------
      0            /usr/bin/php-cgi8.1   81        auto mode
    * 1            /usr/bin/php-cgi7.2   72        manual mode
      2            /usr/bin/php-cgi7.4   74        manual mode
      3            /usr/bin/php-cgi8.0   80        manual mode
      4            /usr/bin/php-cgi8.1   81        manual mode
    Thanks a lot if you have more ideas !
     
  4. There is no apache error while accessing https://server:8080/phpmyadmin
    https://webmail.server.tld ( https://server:8080/webmail ) produce :
    Code:
    [Sat Mar 26 06:49:16.626384 2022] [proxy_fcgi:error] [pid 27877] [client 202.22.143.149:58960] AH01071: Got error 'PHP message: PHP Fatal error:  Array and string offset access syntax with curly braces is no longer supported in /usr/share/phpmyadmin/libraries/url_generating.lib.php on line 231'
    php version is set to php7.4 for this vhost webmail.server.tld
    trying to set it to 7.2 produce : PHP Version is invalid in ISPConfig panel.
     
  5. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have php7.4-json installed?
     
  6. Yes it is
    Code:
    apt list php* --installed
    Listing... Done
    php-apcu-bc/bionic,now 1.0.5-14+ubuntu18.04.1+deb.sury.org+3 amd64 [installed,automatic]
    php-auth-sasl/bionic,now 1.0.6-3 all [installed,automatic]
    php-common/bionic,now 2:92+ubuntu18.04.1+deb.sury.org+2 all [installed,automatic]
    php-gettext/bionic,now 1.0.12-0.1 all [installed]
    php-imagick/bionic,now 3.6.0-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php-mail-mime/bionic,now 1.10.2-0.1 all [installed,automatic]
    php-net-sieve/bionic,now 1.4.1-1 all [installed]
    php-net-smtp/bionic,now 1.8.0-1 all [installed,automatic]
    php-net-socket/bionic,now 1.0.14-2 all [installed,automatic]
    php-pear/bionic,now 1:1.10.13+submodules+notgz+2022032202-2+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php-php-gettext/bionic,now 1.0.12-0.1 all [installed,automatic]
    php-phpseclib/bionic,now 2.0.9-1 all [installed,automatic]
    php-soap/bionic,now 2:8.1+92+ubuntu18.04.1+deb.sury.org+2 all [installed]
    php-tcpdf/bionic,now 6.2.13+dfsg-1ubuntu1 all [installed,automatic]
    php7.2/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php7.2-apcu/bionic,now 5.1.21+4.0.11-7+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.2-bz2/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.2-cgi/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-cli/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-common/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-curl/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-dev/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-fpm/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-gd/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-igbinary/bionic,now 3.2.6+2.0.8-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed,automatic]
    php7.2-imagick/bionic,now 3.6.0-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.2-imap/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-intl/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-json/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.2-mbstring/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-memcache/bionic,now 8.0+4.0.5.2+3.0.9~20170802.e702b5f9+-7+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.2-memcached/bionic,now 3.1.5+2.2.0-14+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.2-msgpack/bionic,now 2.2.0~rc1+2.1.2+0.5.7-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed,automatic]
    php7.2-mysql/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-opcache/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-pspell/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-readline/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.2-recode/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-soap/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-sqlite3/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-tidy/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-xml/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.2-xmlrpc/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.2-xsl/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php7.2-zip/bionic,now 7.2.34-28+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php7.4-apcu/bionic,now 5.1.21+4.0.11-7+ubuntu18.04.1+deb.sury.org+10 amd64 [installed,automatic]
    php7.4-apcu-bc/bionic,now 1.0.5-14+ubuntu18.04.1+deb.sury.org+3 amd64 [installed,automatic]
    php7.4-bz2/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-cgi/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-cli/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-common/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-curl/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-dev/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-fpm/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-gd/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-igbinary/bionic,now 3.2.6+2.0.8-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.4-imagick/bionic,now 3.6.0-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.4-imap/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-intl/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-json/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.4-mbstring/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-memcache/bionic,now 8.0+4.0.5.2+3.0.9~20170802.e702b5f9+-7+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.4-memcached/bionic,now 3.1.5+2.2.0-14+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php7.4-msgpack/bionic,now 2.2.0~rc1+2.1.2+0.5.7-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed,automatic]
    php7.4-mysql/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-opcache/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.4-phpdbg/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.4-pspell/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-readline/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.4-soap/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-sqlite3/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-tidy/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-xml/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php7.4-xmlrpc/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php7.4-xsl/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php7.4-zip/bionic,now 7.4.28-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php8.0-bz2/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-cgi/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-cli/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-common/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-curl/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-fpm/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-gd/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-igbinary/bionic,now 3.2.6+2.0.8-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.0-imagick/bionic,now 3.6.0-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.0-imap/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-intl/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-mbstring/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-memcache/bionic,now 8.0+4.0.5.2+3.0.9~20170802.e702b5f9+-7+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.0-memcached/bionic,now 3.1.5+2.2.0-14+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.0-msgpack/bionic,now 2.2.0~rc1+2.1.2+0.5.7-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.0-mysql/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-opcache/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.0-pspell/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-readline/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.0-soap/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-sqlite3/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-tidy/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.0-xml/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.0-xmlrpc/bionic,now 3:1.0.0~rc3-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.0-xsl/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php8.0-zip/bionic,now 8.0.17-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php8.1-bz2/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-cgi/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-cli/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-common/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-curl/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-fpm/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-gd/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-igbinary/bionic,now 3.2.6+2.0.8-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.1-imagick/bionic,now 3.6.0-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.1-imap/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-intl/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-mbstring/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-memcache/bionic,now 8.0+4.0.5.2+3.0.9~20170802.e702b5f9+-7+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.1-memcached/bionic,now 3.1.5+2.2.0-14+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.1-msgpack/bionic,now 2.2.0~rc1+2.1.2+0.5.7-6+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.1-mysql/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-opcache/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.1-phpdbg/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.1-pspell/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-readline/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.1-soap/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-sqlite3/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-tidy/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    php8.1-xml/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed,automatic]
    php8.1-xmlrpc/bionic,now 3:1.0.0~rc3-4+ubuntu18.04.1+deb.sury.org+10 amd64 [installed]
    php8.1-xsl/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 all [installed]
    php8.1-zip/bionic,now 8.1.3-1+ubuntu18.04.1+deb.sury.org+1 amd64 [installed]
    phpmyadmin/bionic-updates,bionic-security,now 4:4.6.6-5ubuntu0.5 all [installed]
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You could probably upgrade phpmyadmin to a newer version that would work on php7.4, but you might still need to fix your 7.2 setup. Or upgrade to Ubuntu 20.04 and drop 7.2 completely might be a plan.
     
  8. Hi @Jesse Norell ,
    Upgrading to Ubuntu 20.04 is the plan.
    I would have preferred to upgrade from a stable system, but getting rid of PHP7.2 might be the issue.
    ( I can't afford anymore downtime for this standalone server ).
     
  9. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

Share This Page