Moving ISPconfig

Discussion in 'Installation/Configuration' started by juampi, Feb 24, 2006.

  1. Ovidiu

    Ovidiu Active Member

    you are right about those tutorials, the one you gave and the one I found are almost copies of each other.

    About manually moving:

    can you give me some hints:

    - for example how do I get a list of all installed applications? there has to be a dpkg or apt option to get this list, so I could at least duplicate this.
    - about duplicating settings as I am not sure I can duplicate everything manually, what needs to be copied over except for the ispconfig stuff (which is already covered further up in this thread) - /etc /usr /var maybe?
    - anything which you strongly discourage me copying over?
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Run
    Code:
    dpkg -l
    That depends where your configuration files are. Most of them are in /etc.
    The most important parts are covered here: http://www.howtoforge.com/forums/showpost.php?p=16488&postcount=2
     
  3. Ovidiu

    Ovidiu Active Member

    concerning
    want to have a good laugh?

    I copied them over and now I cannot login any longer as I do not remember my root password I was using one of my users which had full acces via sudoers, but when copying those files over to the new system I forgot to copy the sudoers file, now I can login with my user, but no longer do sudo su, no root password, bad thing :-( I guess I'll set it up again, good practice
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    If you have direct access to your server, you might use a Live-CD like knoppix to boot your server, mount your HD and edit the password in /etc/shadow.
     
  5. Ovidiu

    Ovidiu Active Member

    I already read the : recover lost root password threads around here and I tried the lilo trick, before booting sequence, whatever but I failed yesterday, it booted too fast for me to press any key....

    anyway thx for helping :)
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you have a rescue system on your server? Boot into it, mount your hard disk and give yourself a new root password.
     
  7. Ovidiu

    Ovidiu Active Member

    ok, I mounted my /dev/md1 and tried chpasswd as well as passwd but I get this:

    passwd: User not known to the underlying authentication module

    Do you mean me to manually enter the password into /etc/passwd ? I guess I would have to enter it md5 encrypted there? Or how exactly do I achieve this?

    ###edit###

    I answered my own question:

    mount -t ext3 /dev/md1 /mnt/
    root@h898552:~# cd /mnt/
    root@h898552:/mnt#
    root@h898552:/# chroot /mnt
    h898552:/#
    h898552:/# passwd
    Enter new UNIX password:
    Retype new UNIX password:
    passwd: password updated successfully
    h898552:/#

    and again I learned something new :) I REALLY DID IT!!!
     
    Last edited: May 17, 2006
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, you need to chroot. :)
     
  9. Ovidiu

    Ovidiu Active Member

    some more problems:

    in your post further up you give a link to how to dump and restore mysql database.

    you should mention that one needs to create a db by that name before one can import. at least iti did not work for me.

    next one ist this, I get an error whe ntrying to import:

    what could this be? this is my most important database...

    ###edit###

    how can I do this:
     
    Last edited: May 23, 2006
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you use the same MySQL version on both systems?
     
  11. Ovidiu

    Ovidiu Active Member

    I did not solve the last problem yet, but I have a new one:

    I copied over the mysql database and now when I try to restart mysql I get this error:

    any idea why the debian-sys-maint user cannot login anymore?

    ###edit###

    basically its 2 different problems:

    I copied over one site to the new server but the web6_u1 was not inside the mysql db of the new server, so I copied the newest mysql db from the old server to the nwe one. Basically now I cannot restart the mysqld on the new server (see above errors) and I cannot login to the web6_db1 I also copied over although now the web6_u1 user is inside the mysql db.
    2nd problem is a working db that I had already created on the new server is not working anymore.


    ###2nd edit###
    1st problem: http://pacura.ru does not react at all, I get a site not found. I redirected this domain to the new server IP more than 24hours ago then went ahead and transfered the account to the new isp cfg server running debian, like described earlier in this thread - so where is the catch? web6_db1 exists, web6_u1 exists, I can login with phpmyadmin with these info.

    2nd problem: web8_db1 and web8_u1 work to login using phpmyadmin but if I login as web8_u1 I see no databases, if I login as root I see web8_db1 so how can I repair this so that that user sees that DB? ###solved### I logged in with webmin, went to the mysql module and added the web8_u1 user to the database permissions table
     
    Last edited: Jul 24, 2006
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    It's working for me. I get a white page, but it's working. :)
     
  13. Ovidiu

    Ovidiu Active Member

    in between I got a white page too, but no source code???

    by now it works, it looks to as if the DNS update took longer than 24 hours ....
    I hope zice.ro will work too soon... thats the one where I get the shared IP page.
     
  14. todvard

    todvard ISPConfig Developer ISPConfig Developer

    the password for debian-sys-maint user is stored in two places, first encrypted in the mysql database, second in the /etc/mysql/debian.cnf file. I think you overwrote your mysql database with the dump from your old server, which means you will need to copy over the debian.cnf file from the old server as well.
     
  15. Ovidiu

    Ovidiu Active Member

    thx.

    that worked wonderful and I think it is worht mentioning somewhere, like in the FAQ.
     
  16. Ovidiu

    Ovidiu Active Member

    ok, the move went ok, I jsut have one problem left: the stats are no longer compiling on the new server...

    any suggestions what could have went wrong during the move or shall I start loking for "stats no longer compiling" posts?

    also the problem with one of the databases persists:

    any ideas? the mysql version is the same on both systems. I could upgrade wordpress (the application that uses this DB) to the newest version, maybe the error lies within the DB ?
     
    Last edited: Jul 31, 2006
  17. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Run
    Code:
    crontab -e
    and then restart cron:
    Code:
    /etc/init.d/cron restart
    What's in line 12 of web3_db1.sql?
    Is web3_db1.sql emtpy (no tables in it) when you try to restore it from the dump?
     
  18. Ovidiu

    Ovidiu Active Member

    thx for helping, I tried the crontab -e and cron restart solution already, I'll wait and see what the new month brings.

    regarding the DB issues, it got solved here: http://www.howtoforge.com/forums/showthread.php?t=5909

    there was a problem with some backticks. I just cut out the section with the backticks as it was a plugin for wordpress.
     
  19. Ovidiu

    Ovidiu Active Member

    I have no stats showing for august for those sites that I moved from the old server, for the new created sites there is not even a stats folder being created.

    I will look out for the thread dealing with this problem, I just wanted to mention that the stats stopped/never worked on this new system...
     
  20. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Do you have httpd logfiles in /var/log/httpd with the date in the name?

    Do you get any errors when you execute:

    /root/ispconfig/php/php -q /root/ispconfig/scripts/shell/logs.php
     

Share This Page