Moving e-mails from old ISPConfig to new one (diff versions)

Discussion in 'Installation/Configuration' started by miki, Mar 25, 2013.

  1. miki

    miki New Member


    I have an old version of ISPConfig ( which is running on Debian Lenny. Now I would like to install a new Debian Squezze with current version of ISPConfig and move to new server only mailboxes and DB.

    I already installed new ISPConfig according manual The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]. I moved some tables from dbispconfig (tables: client, mail_domain, mail_forwarding, mail_user and sys_user) and copied mailboxes from /var/vmail. I have also installed Roundcube webmail.

    The problem is that I cannot login to mailbox. I tried IMAP, POP3 and webmail.
    In /var/log/mail.log there is

    Mar 25 14:16:47 mail imapd: chdir /var/vmail/domain.tld/user: Permission denied
    Mar 25 14:16:47 mail imapd: [email protected]: Permission denied

    Where could be the problem? Do I need to copy any other table from old dbispconfig?

    Thank you,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure that all folders are owned by user and group vmail and that you use the same imap server (couroer / dovecot( that you used on your otherserver. the ispconfig version does not matter as the folder layout or users have not been changed.
  3. miki

    miki New Member

    I made chown -R vmail:vmail /var/vmail and now I have in mail.log this:
    Mar 25 17:35:15 mail imapd: LOGIN FAILED, user=[email protected], ip=[::ffff:]

    The login and password are still the same. I can login to mailbox with this credentials on old ispconfig from which I export the db. But on this new one I cannot.
  4. miki

    miki New Member

    Now I found out that I can login only to one of 3 mailboxes which I tested. Each of them are different domains.
  5. miki

    miki New Member

    In /var/log/mail.log I have:

    Mar 26 14:32:43 mail authdaemond: zero rows returned
    Mar 26 14:32:43 mail authdaemond: no password available to compare
    Mar 26 14:32:43 mail authdaemond: authmysql: REJECT - try next module
    Mar 26 14:32:43 mail authdaemond: FAIL, all modules rejected

    Could someone tell me where could be the problem?
  6. miki

    miki New Member

    Nobody could help me? Thanks for every helpful information.
  7. miki

    miki New Member


    I find out that in dbispconfig database, table mail_user was empty column login.

Share This Page