Moved half my domains to new vps. but other half still sends to local vps

Discussion in 'ISPConfig 3 Priority Support' started by Jonathon Gilbert, Apr 5, 2019.

  1. hi guys.
    this may have been answered before but im not sure how it would have been worded.

    I have a centos 6.9 server running ispconfig3.0 but it is hosted with a company that i have had no end in issues with.
    so i have created a new hosting on a centos7.4 server running ispconfig 3.1

    i have move 3 of my domains from the old hosting to the new hosting and they are working fine. in and out.
    however when i send a email from an account on the old server (different domain obviously) the email doesnt go to the new hosting, it goes to the old mailbox on the same hosting.

    i have since changed the domain name from "domain" to "domain1" on all of the moved domains so as to retain the emails for a short time before removing the domain entirely. and now the emails arrive anywhere.

    i have updated the old dns records for the moved domains to match what they are on the new hosting

    i have run the resync option.

    EDIT: i now get the error - "Helo command rejected: Host not found (in reply to RCPT TO command)"
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    When you have the same domain name on two servers and send an email to that domain from one of it, then the email must end up on the local server as local delivery has precedence. You have to delete or rename the domain name on the old server to stop that and the dns records must have been changed to point to the new server to get mails delivered to the new system. Please note that DNS changes may take some time, so you cannot expect an immediate change when you alter a DNS record as most systems and email clients cache dns records for up to 24 hours.
     
  3. no worries. i just updated the new message after changing the domains names. just took a while to show in my mail queue.

    Helo command rejected: Host not found (in reply to RCPT TO command)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. im not using the moved domains on both. just the new one. and i think changing the email domain name has worked but now wont send because of this error:
    Helo command rejected: Host not found (in reply to RCPT TO command)
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You can not use non-existing hostnames as most servers will reject the emails then as you can see in the error message that you got. The server hostname and also the email domain name and the domain that you configured has myhostname in postfix must exist in DNS and point to the right server.
     
  7. just another reason im moving away from this hosting. i have found the issue and your right. my old server is not sending out any helo. and this is an issue only because in my centos 7.4 server i have postfix configure to block emails without it.

    however i was advised that if i add my server ip into "mynetworks" inside the postfix main file it should accept it regardless. however this doesnt seem to be working.
    any tricks to this?

    i would update the files to include that data but with this old hosting they have not given me the ability to take snapshots and when i tried to load on a backup application the server was overloaded. so a workaround is needed rather than fixing this particular issue. once i get away from this old hosting it will not be an issue.

    but that is months away


    UPDATE: after adding it into "mynetworks" it now has this error "Temporary lookup failure (in reply to RCPT TO command))"
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You get this error in which case? Sending from old to new, from new to old, from new to new, from old to old or by communicating with an external third party mail system?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    It might be that you are e.g. sending to a domain that does not exist as email domain on that server or you are still using a non existing domain name as mynetworks is to allow relaying, it is no solution to solve issues with non existing domains or your server is not able to resolve dns queries at all.
     
  10. for anyone else that has this issue...
    i have managed to find the issue with adding the servers ip and subnet to "mynetworks"

    - this is not the best way and please update me with a better way...
    but the ip i have used is now - "192.168.1.0/24" (without quotations)
    this means anyone else on that subnet will also pass but in my case that is ok. some cases that will let in additional spam.

    it is now working. and after adding the domain to the whitelist it should not work without being marked as spam.
     

Share This Page