Move primary DNS and SQL

Discussion in 'ISPConfig 3 Priority Support' started by muekno, Oct 6, 2016.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Then check if the bind files of the missing domains are there (without a .err ending) and if these are loaded with the named.conf.local file.

    you can check the domains on the master with:

    dig @localhost mydomain.tld

    where mydomain.tld is the domain name.
     
  2. muekno

    muekno Member HowtoForge Supporter

    Sorry I 'am not a Linux guru but I know Linux very well an I am familar with tools like dig or nslookup. As I wrote there are no bind files at the master server, nor there is included something in the named.conf.local, nor there are any any .err files. nslookup can connect to the master server any query to one of my varios domains result in unknown, whir queries to the old nameserver works fine. All is double checked

    Rainer
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You used the debug mode and ispconfig showed that it wrote the dns files? If this was not shown, then check if you have the dns module enabled in /usr/local/ispconfig/server/mods-enabled/ and the bind plugin in /usr/local/ispconfig/server/plugins-enabled/ and check the dns records (doan_soa and dns_rr table) with phpmyadmin to ensure that you really set the correct server ID (the id of the master).
     
  4. muekno

    muekno Member HowtoForge Supporter

    I did not use the debug mode
    mods-enabled shows lrwxrwxrwx 1 root root 61 Oct 9 19:09 dns_module.inc.php -> /usr/local/ispconfig/server/mods-available/dns_module.inc.php
    plugins-enabled shows lrwxrwxrwx 1 root root 65 Oct 9 19:09 bind_plugin.inc.php -> /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php
    dns_soa and dns_rr phpmyadmin table server shows admin.gerdakloos.de (the master Server) with server_id 1 and table dns_soa and table dns_rr have server_id 1 in all records, tripple checked

    If you will you can get access, the server is reachable from the internet, ispconfig and phpmyadmin. Need a secure way to send passwords.
    Rainer
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The debug mode is the best way to find out why your server is not connecting and I suggested to use it already in post #6.

    Please contact Florian from ISPConfig business support here http://www.ispconfig.org/get-support/?type=ispconfig if you need help by remote login.
     
    muekno likes this.
  6. muekno

    muekno Member HowtoForge Supporter

    OK what I learned, not all errors in debug mode are shown on the master server, I have to check each server. I my case there wer errors on the priDNS, setting the password in phpmyadmin solved it. The ISPConfig version ist now shown as 3.1 on all servers. Still strange that I have to restart mysql when a password is reset, but if you know you can handle it.
    Checked debug mode on all servers, not errors at all.
    But still the old problem still exists, no bind files on the master server.
    Thanks for all the support.
    Rainer
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The debug mode debugs the local server, it shows the debug messages of the server where you run the server.sh script, it does not matter if that's a master or slave.

    I can not help you if you don't post the debug output.

    1) disable the server.sh script on the master as described in debug instructions.
    2) add a record to a dns zone that should be on the master server.
    3) run the server.sh script on the server where this record should be created (in your case the master) and post the output.
     
  8. muekno

    muekno Member HowtoForge Supporter

    Sorry but there is no debug output any more. On each server I did
    comment the line in crontab as discribed here http://www.faqforge.com/linux/debugging-ispconfig-3-server-actions-in-case-of-a-failure/
    do /usr/local/ispconfig/server/server.sh it shows me just finished, it is the same on the master and on each slave.
    following your instaructions I get

    PHP Warning: file_put_contents(/var/lib/named/pri.muekno.de): failed to open stream: No such file or directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 269
    PHP Warning: chown(): Unable to find uid for named in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 270
    PHP Warning: chgrp(): Unable to find gid for named in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 271
    PHP Warning: rename(/var/lib/named/pri.muekno.de,/var/lib/named/pri.muekno.de.err): No such file or directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 291
    PHP Warning: file_put_contents(/var/lib/named/pri.muekno.de): failed to open stream: No such file or directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 269
    PHP Warning: chown(): Unable to find uid for named in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 270
    PHP Warning: chgrp(): Unable to find gid for named in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 271
    PHP Warning: rename(/var/lib/named/pri.muekno.de,/var/lib/named/pri.muekno.de.err): No such file or directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 291
    PHP Warning: file_put_contents(/var/lib/named/pri.muekno.de): failed to open stream: No such file or directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 269
    PHP Warning: chown(): Unable to find uid for named in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 270
    PHP Warning: chgrp(): Unable to find gid for named in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 271
    PHP Warning: rename(/var/lib/named/pri.muekno.de,/var/lib/named/pri.muekno.de.err): No such file or directory in /usr/local/ispconfig/server/plugins-available/bind_plugin.inc.php on line 291
    finished.

    Rainer
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if bind is not installed or it uses a different user and group. Ensure that you have BIND installed and that the BIND settings on the DNS tab under System > Server config in ISPConfig match your system setup.
     
    muekno likes this.
  10. muekno

    muekno Member HowtoForge Supporter

    That was the accurate tip, the entries had names and pathes from SuSE which different from debian.
    Tanks again for your support and patience.
    Rainer
     

Share This Page