Move from Static to dynamic IP causing problems

Discussion in 'Installation/Configuration' started by steve haddlesey, Apr 22, 2015.

  1. steve haddlesey

    steve haddlesey New Member

    I'm running the following configuration;
    Debian 3.2.65-1+deb7u1 x86_64 G

    I have just switched my ISP provider to one that unfortunately does not offer static ip's. I previoulsy had ISPConfig working a treat with 1 static IP and port forwarding but now have run into problems. While it still works using a hostname, when I select any of my websites hosted in ISPConfig they all hit the default website on the debian server that has the default page saying "It Works!" previously each URL would cleanly hit their own sites stored under client0,1 etc.

    Also when adding also hits the same default page and does not go to squirrelmail.
    I'm using frame redirect from my DNS control panel with 1and1 and using to keep the IP address refreshed.

    Any advice would be greatly received. Many thanks in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    A frame redirect can not work here as apache does not get the information which website is requested, so it has to deliver the first website, which is the default vhost.

    What you can try is that you set all your domains and subdomains as cname-records instead of a-records in dns and use the no-ip address as target address. The no-ip address has then to be a dns a-record that points to your current dynamic ip address.

Share This Page