More Amavis/ClamAV errors

Discussion in 'Installation/Configuration' started by spacepills, May 16, 2014.

  1. spacepills

    spacepills Member

    May 16 14:58:33 vps2 postfix/qmgr[21525]: 54224161473: removed
    May 16 14:58:33 vps2 amavis[21610]: (21610-03) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused
    May 16 14:58:34 vps2 amavis[21610]: (21610-03) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused
    May 16 14:58:34 vps2 amavis[21610]: (21610-03) (!)ClamAV-clamd: All attempts (1) failed connecting to /var/run/clamav/clamd.ctl, retrying (2)
    May 16 14:58:38 vps2 amavis[21609]: (21609-03) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused
    May 16 14:58:38 vps2 amavis[21609]: (21609-03) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (All attempts (1) failed connecting to /var/run/clamav/clamd.ctl) at (eval 114) line 603.\n
    May 16 14:58:38 vps2 amavis[21609]: (21609-03) (!)WARN: all primary virus scanners failed, considering backups
    May 16 14:58:40 vps2 amavis[21610]: (21610-03) (!)connect to /var/run/clamav/clamd.ctl failed, attempt #1: Can't connect to UNIX socket /var/run/clamav/clamd.ctl: Connection refused
    May 16 14:58:40 vps2 amavis[21610]: (21610-03) (!)ClamAV-clamd av-scanner FAILED: run_av error: Too many retries to talk to /var/run/clamav/clamd.ctl (All attempts (1) failed connecting to /var/run/clamav/clamd.ctl) at (eval 114) line 603.\n
    May 16 14:58:40 vps2 amavis[21610]: (21610-03) (!)WARN: all primary virus scanners failed, considering backups

    Amavis was stopped, emails weren't working (temporary lookup failure) So went through and restarted various services, turned out to be amavis stopped.

    this happened literally randomly.
    I had an issue similar before which was sorted thanks to a page file.
    I added a new email domain, all the emails were working, all of the sudden, get a call from a client saying it's broken.

    Any help?
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    The entries in your posted log look like clamav daemon stopped, not amavis.
    Maybe amavis crashed later on because of this. I remember I had such behaviour some time ago on my server.
    It can happen that clamav fails updating (downloads an invalid virus database) and stops working after this.
     
  3. spacepills

    spacepills Member

    Hi, yeah you are very right, I realised that, started clamav-daemon then restarted amavis, I completely missed it as was panicking as I have several clients and all emails stopped working! Still no idea what caused it but I know for future where to look!

    Thanks for your help mate!
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have a look in clamav log. You can see if it crashed or failed to reload in there.
     
  5. WhitcombeRD

    WhitcombeRD New Member

    I get this error after a while of running.

    When i checked the ClamAV log i was getting errors about memory allocation. Running free -m confirmed id run out of memory. My only solution was to stop ClamAV running.
     

Share This Page