Mono httpd error on restart

Discussion in 'Installation/Configuration' started by gr33d, Nov 10, 2009.

  1. gr33d

    gr33d New Member

    Did a search here for "mono" and no results :/ Have ISPConfig 3 setup and running (CentOS 5.4 perfect setup) great!

    Compiled mono-, xsd-2.4.2 and mod_mono-2.4.2 in my /opt directory and can't seem to make the ISPConfig2-style directives (found here) work right--if thats even the way to do it.

    my directives were:
    MonoAutoApplication enabled
    MonoDocumentRootDir "/var/www/clients/client1/web5/web/"
    MonoServerPath [COLOR="Red"]default [/COLOR]"/opt/mono/bin/mod-mono-server2"
    MonoApplications [COLOR="Red"]default [/COLOR]"/:/var/www/clients/client1/web5/web/"
    Alias /mono "/var/www/clients/client1/web5/web/"
    <Directory /var/www/clients/client1/web5/web/>
    SetHandler mono
    MonoSetServerAlias [COLOR="Red"]default[/COLOR]
    AddHandler mod_mono .aspx .ascx .asax .ashx .config .cs .asmx
    I think there are a few links within /var/www, but I think the actual path is /var/www/clients/client1/web5/web. Not sure about "default" either.

    error after restarting httpd:
    Invalid command 'MonoAutoApplication', perhaps misspelled or defined by a module not included in the server configuration

    Any ideas? Thanks in advance!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if mod_mono is not loaded in your apache server.
  3. gr33d

    gr33d New Member

    My mistake--mod_mono.conf was loaded into /etc/httpd/conf instead of /etc/httpd/conf.d

    I copied mod_mono.conf into /etc/httpd/conf.d and on "service httpd restart" I receive:

    Stopping httpd: [ OK ]
    Starting httpd: [Wed Nov 11 08:17:27 2009] [crit] (13)Permission denied: Failed to attach to existing dashboard, and removing dashboard file '/tmp/mod_mono_dashboard_XXGLOBAL_1' failed (Operation not permitted). Further action impossible.
    [ OK ]

    service httpd reload reloads without error. However my page, test.aspx:

    <%@ Page Language="C#" %>
       <title>Sample Calendar</title>
    <asp:calendar showtitle="true" runat="server">
    still doesn't load. (500 Internal Server Error)

    /var/log/httpd/error_log shows:
    [Wed Nov 11 08:41:53 2009] [error] (70014)End of file found: read_data failed
    [Wed Nov 11 08:41:53 2009] [error] Command stream corrupted, last command was -1
    System.UnauthorizedAccessException: Access to the path "/path/to/web" is denied.

    /path/to/web in error_log is a symlink to /var/www/clients/client1/web5/web. the symlink permissions are root:root. the permissions of /var/www/clients/client1/web5 and its subdirectory web are all web5:client1.

    Is this a permissions problem? or something else?
  4. gr33d

    gr33d New Member


    I added a temporary directive to /etc/httpd/conf/sites-available/domain.tld.vhost:

    <VirtualHost *:80>
    DocumentRoot /var/www/clients/client1/web5/web/
    ServerName aspx.domain.tld
    Alias /demo /opt/mono/lib/xsp/test
    MonoApplications "/demo:/opt/mono/lib/xsp/test"
    MonoServerPath /opt/mono/bin/mod-mono-server2
    <Directory /opt/mono/lib/xps/test>
    SetHandler mono

    received 403 Forbidden when accessing aspx.domain.tld/demo

    chown -R apache:apache /opt/mono/lib/xsp/test
    service httpd reload

    same 403 error

    also tried chmod -R 777 /opt/mono/lib/xsp/test

    same 403 error

    realized the DocumentRoot directive was wrong for this test, and changed to DocumentRoot /opt/mono/lib/xsp/test and tried the above again.

    No luck so far. What is the different between sites-available and sites-enabled in /etc/httpd/conf?
  5. Mosquito

    Mosquito New Member

    Did you ever get this to function? I'd like to have mono available on my ISPConfig sites also.

Share This Page