Monitor shows false update state

Discussion in 'ISPConfig 3 Priority Support' started by sheshes, May 4, 2014.

  1. sheshes

    sheshes Member HowtoForge Supporter

    After update to 3.5.4 p1 my monitor section appears to be stuck on older, already installed updates, therefore always appearing blue with 1 warning.

    I guess something has been overwritten or a symlink disappeared. Could someone point me out which files are read by monitor plugin so I can troubleshoot the error?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which Linux distribution do you use?
     
  3. sheshes

    sheshes Member HowtoForge Supporter

    Ubuntu 14.04
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    please post the output of:

    apt-get upgrade
     
  5. sheshes

    sheshes Member HowtoForge Supporter

    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    The following packages have been kept back:
      libdb-dev
    0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so the monitor is working correctly when it shows that there are pending updates as you havent all updates installed. The libdb-dev updat has been kept back, thats why it was not installed when you run apt-get upgrade.

    you can install it either by running:

    apt-get install libdb-dev

    or by running:

    apt-get dist-upgrade
     
  7. sheshes

    sheshes Member HowtoForge Supporter

    I have installed the package that was held back. the output of apt-get upgrade is now
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Calculating upgrade... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    ISPConfig shows the update state of a week old:

    Code:
    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following packages will be REMOVED:
    libdb5.1-dev
    The following NEW packages will be installed:
    libdb5.3-dev
    The following packages will be upgraded:
    libdb-dev
    1 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
    Remv libdb5.1-dev [5.1.29-7ubuntu1] [libdb-dev:i386 ]
    Inst libdb-dev [5.1.6] (1:5.3.21~exp1ubuntu1 Ubuntu:14.04/trusty [i386]) []
    Inst libdb5.3-dev (5.3.28-3ubuntu3 Ubuntu:14.04/trusty [i386])
    Conf libdb5.3-dev (5.3.28-3ubuntu3 Ubuntu:14.04/trusty [i386])
    Conf libdb-dev (1:5.3.21~exp1ubuntu1 Ubuntu:14.04/trusty [i386])
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe cron is not working correctly anymore. try a:

    service cron restart
     
  9. sheshes

    sheshes Member HowtoForge Supporter

    PERFECT Till,

    Everything's back to normal now. Thanks for help
     

Share This Page