"Monitor" Doesn't show anything

Discussion in 'Installation/Configuration' started by xstnc, Aug 5, 2011.

  1. xstnc

    xstnc New Member

    Hi,

    I've just done a setup of two servers running ISPConfig 3 and Ubuntu 10.04.
    The master server contains all roles for ISPConfig and the second server is just a DNS (and registrered such in the "system" tab).

    But when I go to "Monitor" the second server doesn't have any information at all.

    What do I have to do, to let the master server gather the information from the second server?
     
  2. till

    till Super Moderator

    Thats most likely a problem with mysql permissions. The slave server is not able to connect to the master, so he can not update the monitor.

    Have you entered the hostname of the master mysql server while you setup the slave in the ispconfig installer as requested and not the IP of the master? If you entered the IP, then the connection will fail. Another possible problem is if you did not alter the /etc/hosts files on both servers as described in the multiserver guide, the connection will only work if both servers can resolve their hostnames in the same way.
     
  3. xstnc

    xstnc New Member

    The install of ISPConfig on the second server went OK.
    And I made sure to use hostnames for every question it asked.

    I had no problems setting it up, and getting things to whirl around.
    (No MySQL connection problems).

    I can still access the main server from mysql command on the second server.

    I did not however edit the hosts file, and will have a read in the multi servers guide to see what it actually wants me to input.

    But both servers can ping eachother via internet, so the name must resolve somewhere?
     
  4. till

    till Super Moderator

    You can test the mysql connectin like this: Open the file /usr/local/ispconfig/server/lib/config.inc.php. Inside the file, you will find login details to the local database and to the remote (master) database. Use the login details for the master database to execute this command on the shell of the slave to test the connection:

    mysql -h masterhostname -u username -p ispconfigdatabasename

    The command will query you the for the password.
     
  5. xstnc

    xstnc New Member

    The Mysql connection was tested OK from the beginning.
    Added the host file records, as you said - and now it works!

    Thanks for the great tip! :)
     
  6. haluk yildirim

    haluk yildirim New Member

    Monitor tab is blank

    Hi,

    I did install several ISPConfig 3 on several fedora 14 servers. everything is running as normal except, after updates from 3.0.4.x, monitor tab does not display anything. When you click on the "show server state" items on the left menu, they work except show overview.

    I have the same problem on several installations.
    Tried with different browsers.
    What am I doing wrong? and how can I fix it ?

    Thank you

    [​IMG]
     
    Last edited: Jan 11, 2012
  7. till

    till Super Moderator

    Please install ISPConfig 3.0.4.2 as this fixes the monitor bug from ISPConfig 3.0.4.
     
  8. haluk yildirim

    haluk yildirim New Member

    Hi Till,

    Hi Till,

    This screen jpg is after 3.0.4.2.

    thank you for your quick reply.
     
  9. till

    till Super Moderator

    Might be a problem with your php configuration, e.g. you might have disabled some functions. Check the apache error.log.
     
  10. haluk yildirim

    haluk yildirim New Member

    apache error msg

    Hi Till,

    PHP Deprecated: Call-time pass-by-reference has been deprecated in /usr/local/ispconfig/interface/web/monitor/show_sys_state.php on line 199, referer: https://mail.bosspacific.com.au:8080/index.php


    Any idea?
     
  11. haluk yildirim

    haluk yildirim New Member

  12. till

    till Super Moderator

    Thats astonished my a bit as reporting of deprecated warnings is disabled by default. So if you see the error, then the ispconfig version is either not 3.0.4.2 or you have some functions like ini_set disabled in your php.ini file or you have the constant "DEVSYSTEM" enabled in your config.inc.php file for the ISPConfig interface or the error is from a tomepoint before the 3.0.4.2 update was installed.
     
  13. haluk yildirim

    haluk yildirim New Member

    thanks till,

    definitely 3.0.4.2. but i will chk other php setting and I will get back to you .

    Thank you very much for your really quick replies.

    haluk
     
  14. haluk yildirim

    haluk yildirim New Member

    version 3.0.4.2

    [​IMG]
     
  15. haluk yildirim

    haluk yildirim New Member

    snipped php.ini

    my php.ini:

    Default Value: E_ALL & ~E_NOTICE
    ; Development Value: E_ALL | E_STRICT
    ; Production Value: E_ALL & ~E_DEPRECATED
    ; http://www.php.net/manual/en/errorfunc.configuration.php#ini.error-reporting
    error_reporting = E_ALL & ~E_NOTICE

    ; This directive controls whether or not and where PHP will output errors,
    ; notices and warnings too. Error output is very useful during development, but
    ; it could be very dangerous in production environments. Depend
     
  16. haluk yildirim

    haluk yildirim New Member

    config.inc.php

    config.inc.php



    //** Application
    define('ISPC_APP_TITLE', 'ISPConfig');
    define('ISPC_APP_VERSION', '3.0.4.2');
    define('DEVSYSTEM', 0);
     
  17. till

    till Super Moderator

    - Is the deprecated error the only error that you get in the apache error.log?
    - Do you have any aliases for "monitor" defined in your apache configuration?
    - Do you have any functions disabled in with the disable_functions directive in php.ini?
     
  18. haluk yildirim

    haluk yildirim New Member

    solved temporaraly

    hi till,

    http://www.nakedtechnologist.com/?p=115

    could you please chk this link?

    I did php.ini modification "allow_call_time_pass_reference = on" .

    after this it worked but according to article it is until next time!!!

    haluk
     
  19. till

    till Super Moderator

    This should not be nescessary as passing by reference is not required and ispconfig disables the warning automatically.

    See /usr/local/ispconfig/interface/lib/app.inc.php Line 39:

    @ini_set('error_reporting', E_ALL & ~E_NOTICE & ~E_DEPRECATED);

    This works fine here with current PHP versions so my guess is that you have the ini_set function disabled in php.ini or something similar so that ISPConfig can not set the required error reporting level.

    Either you enable ini_set in php.ini again so that ispconfig can set the error reporting level or you change the error_reporting in php.ini to:

    error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

    and restart apache2.
     
  20. haluk yildirim

    haluk yildirim New Member

    Hi Till,

    This is from php.ini......


    ; This directive allows you to enable and disable warnings which PHP will issue
    ; if you pass a value by reference at function call time. Passing values by
    ; reference at function call time is a deprecated feature which will be removed
    ; from PHP at some point in the near future. The acceptable method for passing a
    ; value by reference to a function is by declaring the reference in the functions
    ; definition, not at call time.
    This directive does not disable this feature, it
    ; only determines whether PHP will warn you about it or not. These warnings
    ; should enabled in development environments only.
    ; Default Value: On (Suppress warnings)
    ; Development Value: Off (Issue warnings)
    ; Production Value: Off (Issue warnings)
    ; http://www.php.net/manual/en/ini.core.php#ini.allow-call-time-pass-reference
    allow_call_time_pass_reference = on


    I hope it helps..

    Thank you for your help..

    Haluk
     

Share This Page