Monit Problem

Discussion in 'HOWTO-Related Questions' started by VolkerSt, Dec 10, 2006.

  1. VolkerSt

    VolkerSt New Member

    Hi there,

    i installed Monit with Falkos HowTo. Monit seems to run but i cant get a Connection via the Browser. The Browser wants to load the page but it doesnt work. Firewall is off, no Personal-Firewall is running.

    Do you have any suggestions?

    Regards
    Volker
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    ?
     
  3. VolkerSt

    VolkerSt New Member

    Netstat:

    tcp 0 0 *:2812 *:* LISTEN 25071/monit

    iptables -L
    FATAL: Could not load /lib/modules/2.6.18.2/modules.dep: No such file or directory
    iptables v1.2.11: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.


    Regards

    Volker
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you try https or http to connect to monit?
     
  5. VolkerSt

    VolkerSt New Member

    Hi!

    I tried https and http... Both didnt work.

    Regards

    Volker
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Are there any error messages in your browser? Have you tried with Firefox, it has better error messages than IE.
     
  7. VolkerSt

    VolkerSt New Member

    Hi!

    Nothing happens. Firefox and IE with https generates a blank screen, continous loading. With http: I got a "Page not found"...

    Regards

    Volker
     
  8. falko

    falko Super Moderator ISPConfig Developer

    When you try to connect, run
    Code:
    netstat -tap
    at the same time. Do you see your workstation in the output?
     
  9. VolkerSt

    VolkerSt New Member

    hi falko!

    Yes, i see my Workstation:

    Code:
    tcp        0      0 serverXXX.XXXX:2812 pXXXXXXXX.dip.t-di:2620 SYN_RECV   -
    tcp      112      0 serverXXX.XXXX:2812 pXXXXXXXX.dip.t-di:2721 CLOSE_WAIT -                                   
    tcp      112      0 serverXXX.XXXX:2812 pXXXXXXDE.dip.t-di:2741 CLOSE_WAIT -                                   
    tcp      112      0 serverXXX.XXXX:2812 pXXXXXXDE.dip.t-di:2755 CLOSE_WAIT -                                  
    
    Does this help you?

    Regards

    Volker
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Yes, that helps.
    My guess right now is that you did something wrong when you created the SSL cert for monit. Please create it again and accept all the default values.
     
  11. VolkerSt

    VolkerSt New Member

    Youre RIGHT! Thank you, its working!!!

    :) :)

    Regards

    Volker
     
  12. misterm

    misterm Member HowtoForge Supporter

    Hello with all

    I have a small problem, concerning the installation of “monit”, I made exactly as in the “howto” that “falko” to create, but I is not the port which opens, by making this command:

    MM:confused:
     
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you try
    Code:
    /etc/init.d/monit restart
    ?
    Does the monit configuration file look like the one from the tutorial?
     
  14. misterm

    misterm Member HowtoForge Supporter

    Hello falko

    I made exactly, like the “howto” present under “howtoforge”, the “daemon” starts, but when I connect myself with the port “2812”, I is nothing which is posted, I have to forget something, configuration of the server, debian 4.0….

    MM;)
     
  15. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/monit/monitrc?
     
  16. misterm

    misterm Member HowtoForge Supporter

    Hello falko

    has my file "/etc/monit/monitrc"

    MM;)
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Do you use

    Code:
    set httpd port 2812 and
         SSL ENABLE
         PEMFILE  /var/certs/monit.pem
         allow admin:test
    or

    Code:
    set httpd port 2812 and
    SSL ENABLE
    PEMFILE  /var/certs/monit.pem
    allow admin:test
    ? The leading spaces are important.
     

Share This Page