Monit page is blank

Discussion in 'ISPConfig 3 Priority Support' started by concept21, Apr 16, 2017.

  1. concept21

    concept21 Member

    The Monit page is blank inside my ISPConfig panel. How do I correct it? But when I issue command "monit summary", it can show mysql and apache running well.

    My system is Ubuntu 16.04 ISPConfig 3.1.2
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which URL do you use for monit? Newer browsers will block iframe includes under some circumstances like no https or different domain, so it might be that your browser blocked the monit page to be loaded inside the ispconfig page.
     
  3. concept21

    concept21 Member

    I simply put it as following. Are they correct?
    http://my_VM_main_ip:2812/

    and my file /etc/monit/monitrc is:
    set httpd port 2812 and
    use address my_VM_main_ip
    allow 0.0.0.0/0.0.0.0

    I don't need password or https because all services are in one VM.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig interface uses https?
     
  5. concept21

    concept21 Member

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you should try to run monit with https as well. It is very likely that your browser blocks an http iframe content (monit) within a https website (ispconfig).
     
  7. concept21

    concept21 Member

    OHHOHOH!!! IT WORKS WITH SSL ENABLED!!! THANKS! :D
     
  8. concept21

    concept21 Member

    A new problem arises!
    postfix cannot be enabled. Monit shows errors message:
    ==============
    Process 'postfix' Initializing - start pending
    File 'master_bin' Does not exist
    ==============
    How to correct it? Where is the file master_bin? :mad:
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the monit config file where you configured the services, there seems to be a problem in the postfix part.
     

Share This Page