Monit page blank inside ISPConfig

Discussion in 'Installation/Configuration' started by philgardner, Nov 27, 2017.

  1. philgardner

    philgardner Member

    I followed this tutorial https://www.howtoforge.com/tutorial/server-monitoring-with-munin-and-monit-on-ubuntu-14-04/2/ (for Monit only) exactly. I can access the Monit page outside ISPConfig at https://server1.example.com:2812/, but inside ISPConfig the iframe that should contain Monit is blank. I have filled in the System > Server Config fields for Monit correctly. The iframe html is:

    <iframe src="https://username: password@server1.example.com:2812/" width="100%" height="1000" frameborder="0" style="overflow:visible;" kwframeid="4"></iframe>
    I have added a space before 'password' to prevent [colon]p becoming :p!

    I have tried this in Chrome, Firefox and Internet Explorer, with the same result in each. Any suggestions?
     
    Last edited: Nov 27, 2017
  2. ahrasis

    ahrasis Active Member

    What did your error logs say about it?
     
  3. philgardner

    philgardner Member

    I haven't found anything relevant in syslog, ispconfig.log or the Apache error.log – is there anywhere else I should look?
     
  4. ahrasis

    ahrasis Active Member

    Last edited: Nov 30, 2017
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Its probably your browser which prevents the content to be shown in the iframe. Current browsers don't like it when you pass auth information in an URL. There will be a workaround for that new browser nehaviour in ISPConfig 3.2.
     

Share This Page