[Mon Sep 03 13:24:26 2007] [error] an unknown filter was not added: PHP

Discussion in 'General' started by vaio1, Sep 3, 2007.

  1. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Hi guys,

    I have seen my error_log and there are thousand of these lines:

    Code:
    [Mon Sep 03 13:24:26 2007] [error] an unknown filter was not added: PHP
    Why?!?

    in the httpd.conf there is:

    AddType application/x-httpd-php .php .php3 .php4

    thanks
     
    Last edited: Sep 3, 2007
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please change the setting as described in the two posts that I linked above. The default setting adds addtype and filter which produces the warning that you posted above.
     
  4. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Nothing to do
    The problem remain the same.

    thanks
     
  5. mccharlet

    mccharlet Member HowtoForge Supporter

    I find a solution on a post
    I have the reponse on the annexe file
     

    Attached Files:

  6. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    This is not a solution only waste time.
    The problem persist.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The solutions above solve the problem definately.

    1) Which linux distribution do you use?
    2) Which setting did you select for the apache php in config.inc.php?
    3) Have you changed a website, e.g. the quota setting of a site, afterwards and clicked on the save button?
     
  8. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    1) Which linux distribution do you use?
    ----> Fedora 7

    2) Which setting did you select for the apache php in config.inc.php?
    ----> which settings ... all?!

    3) Have you changed a website, e.g. the quota setting of a site, afterwards and clicked on the save button?
    ----> no
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    2) There is no setting 'all'. Please add the setting 'addtype' as described in the post that I linked above for non suse 10.2 setups!

    3) You must change a website.

    Post #5 of the thraed from falko:

    Did you read the thread at all, that I posted? Sometimes I really dont know why I post links to threads if poeple dont read them and then complain that the solution in the thread that they did not read does not work ;)
     
  10. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Dear Till I have read the posted articles but the solution doesn't seem to work.

    As I written before I have added the string: AddType application/x-httpd-php .php .php3 .php4

    thanks
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    It works!

    You should not add the string 'AddType application/x-httpd-php .php .php3 .php4'. You should add the word 'addtype'. The options of the variable are described in config inc.php. To make it absolutely clear:

    1) Open the file /home/admispconfig/ispconfig/lib/config.inc.php in a editor of your choice.
    2) change the apache2_php variable, so that it looks EXACTLY like this:

    $go_info["server"]["apache2_php"] = 'addtype';

    3) Save the file.
    4) Go to the ISPConfig interface, cahnge a website and click on the save button.
     
  12. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    Ups Sorry, :p
    You are right! :cool:
     

Share This Page