Discussion in 'Installation/Configuration' started by guimnk, May 12, 2010.

  1. guimnk

    guimnk Member

    Hi all..

    When I change the php module to MOD-PHP in my site, the webmail alias says:

    Warning: Unknown: open_basedir restriction in effect. File(/usr/share/webmail/index.php) is not within the allowed path(s): (/var/www/clients/client9/web3/web:/var/www/clients/client9/web3/tmp:/usr/share/php5) in Unknown on line 0
    Warning: Unknown: failed to open stream: Operation not permitted in Unknown on line 0
    Fatal error: Unknown: Failed opening required '/usr/share/webmail/index.php' (include_path='.') in Unknown on line 0
    If I change to FastCGI, this problem is fixed. But, I need to use modphp because fastcgi uses more memory...

    How can I do to fix it? I'm using roundcube located in /usr/share/webmail and my webmail.conf is:

    # Adaptacao para webmail macromind
    Alias /webmail /usr/share/webmail
    <Directory /usr/share/webmail>
            Options Indexes FollowSymLinks
            DirectoryIndex index.php
            <IfModule mod_php5.c>
                    AddType application/x-httpd-php .php
                    php_flag magic_quotes_gpc Off
                    php_flag track_vars On
                    php_flag register_globals Off
                    # php_flag safe_mode Off
                    php_value include_path .
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can set the open_basedir path on the options tab of the website.
  3. guimnk

    guimnk Member

    open_basedir = /usr/share/webmail ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, appended by : at the end to the other paths that are already in that field.
  5. guimnk

    guimnk Member

    I set in option tab:

    php_admin_value open_basedir /usr/share/webmail

    Thanks Till

Share This Page