mod_ruby causing apache segfault opensuse 11.4 x64

Discussion in 'Installation/Configuration' started by jeff8000, May 14, 2011.

  1. jeff8000

    jeff8000 New Member

    I am trying to solve a problem with mod_ruby on ISPConfig3. The apache server crashes when started and this is what the system log shows:

    httpd2-prefork[16090]: segfault at 58 ip 00007f055058cb76 sp 00007fff34ae4760 error 4 in libapr-1.so.0.4.2[7f0550573000+2f000]

    using gdb, I was able to track the problem down to mod_ruby (1.3.0)

    #0 0x00007ffff7702b76 in apr_palloc () from /usr/lib64/libapr-1.so.0
    #1 0x00007ffff76fa3f1 in apr_array_push () from /usr/lib64/libapr-1.so.0
    #2 0x00007ffff2438e15 in ruby_cmd_require (cmd=0x7fffffffe650, dconf=0x7ffff838a688, arg=0x7ffff8386a20 "apache/ruby-run") at ruby_config.c:328

    I then disabled mod_ruby and apache would then start properly.

    I have tried mod_ruby-1.2.6 with the same results, does anyone know how to fix this problem?

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to find a mod_ruby package from a different repository which is not broken.
     
  3. mujo

    mujo New Member

    mod_ruby 1.3 and ispconfig 3 and apache 2.2.17

    Hi, i can see that this thread was open a while ago, but i just installed
    on opensuse x86_64 and get the same segment error,
    tried the different repository but that did not work.. but heh?
    is that really it?
    Such a great product ispconfig.. but can i run it without mod_ruby..?


    Is there a workaround?
    does anyone know if there will be one?

    cheers,
    j
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not require mod_ruby internally. So if you dont plan to host ruby websites, then you can skip the installation of the mod_ruby module.

    You might want to ask that the OpenSuSE developers which made the broken packages.

    For ISPConfig we recommend to use Debian or Ubuntu Linux, its much more stable then OpenSuSE when used with ISPConfig 3 and easier to install and update too.
     

Share This Page