mod_rewrite is not working with htaccess

Discussion in 'HOWTO-Related Questions' started by belick, Oct 26, 2006.

  1. belick

    belick New Member

    I tried all solotions posted on this forum, this is my httpd.conf:

    Code:
    <Directory /srv/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /srv/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /srv/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    and this is my .htaccess:
    Code:
    RewriteEngine on
    
    RewriteRule ^(.*)\.html$ index.php?Level1=$1
    RewriteRule ^$ under_constructions.htm
    
    Sometime I got error 500, and somtime 430.

    When I remove the .htaccess file the website shows fine.

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in Apache's error log?
     

Share This Page