mod_rewrite and ISPConfig

Discussion in 'General' started by poisen, Jan 24, 2008.

  1. poisen

    poisen New Member

    I have a problem with mod_rewrite. I'm running ISPConfig 2.2.18 on my server and I just can't get it working.

    Got the following configuration in my .htaccess file:

    PHP:
    RewriteEngine On

    AuthType Basic
    AuthName 
    "Members Only"
    AuthUserFile /srv/www/web22/web/dev/.htpasswd
    <limit GET PUT POST>
    require 
    valid-user
    </limit>

    RewriteRule ^preise.html$ /index.php?section=preise
    RewriteRule 
    ^sitemap.html$ /index.php?section=sitemap
    I also added the following to the httpd.conf in /etc/apache2/, left everything else the way it was.

    PHP:
    <Directory />
       
    Options FollowSymLinks
       AllowOverride All
    </Directory>
    Now everything is running so far but if I try to access sitemap.html for example, I get a 404 error. So I don't know now if there is something I can add to the apache directives in the ISPConfig configuration, tried just about everything now but I don't know what else to do now.

    I'd be thankful if anybody could help me out here.

    -Eddie
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Try this in the Apache Directives field:

    Code:
    <Directory /srv/www/web22/web>
       Options +FollowSymLinks
       AllowOverride All
    </Directory> 
     
  3. orfi

    orfi New Member

    added in suse11 (php5) /etc/apache2/vhosts/Vhosts_ispconfig.conf :

    <IfModule mod_rewrite.c>
    <Directory /srv/www/web22/web>
    Options +FollowSymLinks
    AllowOverride All
    </Directory>
    </IfModule>
    ------------------------
    but if we restart ispconfig we loose this settings

    then i added this in the window for apache directives

    thank you again Falko
     
    Last edited: Oct 20, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    You must add this to the Apache Directives field.
     

Share This Page