Discussion in 'Installation/Configuration' started by nic21rin, Jan 6, 2007.

  1. nic21rin

    nic21rin New Member

    I have been running ispconfig for a while now and everything is running great but i have a problem when i am trying to install mod_python.

    First when i try to install mod_python th whole system thinks the apache version is 1.3, it is 1.3 for the ispconfig system but 2.0.55 for the serving pages.

    does any one know how to get mod_python installed.


  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    how do you try to install it?
    By hand (compiling the sources) or with a package manager of you distro?
    Cause in the second case, the packagemanager knows about apache2 but not abtout 1.3 cause that's installed manually.
    But if you compile it you should be able to enter the path for the necessary apachefiles + dirs. Take a look at ./configure --help (or better with a | more ;) ), that should tell you which parameters are necessary.
  3. nic21rin

    nic21rin New Member

    I have tryed installing mod_python using the --with-apache and --with-python and also --with-python_src and i still get an error installing, the error is error linking python.

    Iv no idea now how to install mod_python with ispconfig other than forcing the install which i don't want to do.

    Any ideas.

  4. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use?
    Did you install the Apache package that came with your distribution, or did you compile it from the sources?

Share This Page