mod_mono apache 2.2

Discussion in 'Server Operation' started by ColdDoT, Mar 6, 2006.

  1. ColdDoT

    ColdDoT New Member


    i want to run apache
    i followed a tut to do it.
    i have installed
    -apache 2.2

    everything works like a charm but when i was compiling mod_mono the config script can't find out whitch version my apache is my ./configure command is

    ./configure --prefix=/var/server/mod_mono --with-apxs=/var/server/webserver/apache/bin/apxs

    then i got
    checking for --with-apxs... /var/server/webserver/apache/bin/apxs executable, good
    checking for --with-apr-config... not specified
    checking for Apache libexec directory... /var/server/webserver/apache/modules
    checking for Apache sysconf directory... /var/server/webserver/apache/conf
    checking for Apache include directory... -I/var/server/webserver/apache/include
    checking Apache version... configure: error: Confused on apache version. Please report this and send config.log

    i have also tryed
    ./configure --prefix=/var/server/mod_mono --with-apxs=/var/server/webserver/apache/bin/apxs --with-apr-config=/var/server/webserver/apache/bin/apr-1-config

    but then i says that my apache version is 1.3 and thats not correct

    i don't know how to solve it and i can't find anything about it on google
    my config.log files can you find here
    try 1
    try 2

    greets kevin
  2. falko

    falko Super Moderator ISPConfig Developer

    Does mod_mono already support Apache 2.2? It's pretty new...
  3. ColdDoT

    ColdDoT New Member

    on the site sais it will.
    but on what searching. no it don't

    but is there maybe a work around ?
  4. 22hosting

    22hosting New Member

    I have to say that I can confirm this error as well. Hence *BUMP* this thread. Does anyone have a solution yet?
    Live sex
    Last edited: Aug 22, 2011
  5. falko

    falko Super Moderator ISPConfig Developer

    I guess I have to try myself and write a tutorial about it some day... ;)
  6. mintaka

    mintaka New Member

    Not so much a solution, but after wasting all night on this I do at least have a work-around. Had the same issue myself - mod_mono doesn't compile against Apache 2.2.2 - it seems the apache version checking routine invoked when running mod_mono's ./configure fails to compile now resulting in the erroneous reporting of version 1.3:

    Didn't have the skills to fix that, so I just forced the selection of Apache 2.2 by editing the file "configure" inside the mod_mono source directory. You'll find a couple of lines that say:


    Change those lines to 2.2 and ./configure sets the build up for a successful compile.

    Hope this helps.

Share This Page