mod_layout

Discussion in 'HOWTO-Related Questions' started by mavgh1, Apr 1, 2006.

  1. mavgh1

    mavgh1 New Member

    I'm running SuSE 9.3
    I have installed mod_layout and is not working(nothing appears in webpage)
    Any sugestion ?
     
  2. falko

    falko Super Moderator

    Is there anything in the Apache error log?
     
  3. mavgh1

    mavgh1 New Member

    error_log

    I have installed mod_layout 4.0.1a

    The message was :

    All done.
    |
    | You will need to add the directive:
    | LoadModule layout_module modules/liblayout.so
    | So that you can begin to use mod_layout.
    | Thanks for installing mod_layout.

    When I add LoadModule to httpd.conf
    LoadModule layout_module modules/liblayout.so
    and try to restart Apache the message is
    Cannot load /srv/www/modules/liblayout.so into server: /srv/www/modules/liblayout.so: cannot open shared object file: No such file or directory

    When I add LoadModule to httpd.conf
    LoadModule layout_module /usr/lib/apache2/liblayout.so

    In VirtualHost I added
    <VirtualHost>
    LayoutFooter "<P>This is domain.ro<P>"
    </VirtualHost>

    restart Apache evrything OK but nothing appears in WebPage
    In Apache error_log I have nothing
     
  4. till

    till Super Moderator

    Please run:

    updatedb

    and then:

    locate liblayout.so
     
  5. mavgh1

    mavgh1 New Member

    locate liblayout.so

    server1:~ # locate liblayout.so
    /srv/www/public-html/mod_layout/.libs/liblayout.so
    /usr/lib/apache2/liblayout.so

    The second line is truth liblayout.so exists
    But the first line is false /srv/www/public-html/mod_layout/.libs/liblayout.so doesn't exist
     
  6. falko

    falko Super Moderator

    If that was true, then locate wouldn't show it.
    What's the output of
    Code:
    ls -l /srv/www/public-html/mod_layout/.libs/liblayout.so
    ?
     
  7. mavgh1

    mavgh1 New Member

    output

    server1:~ # ls -l /srv/www/public-html/mod_layout/.libs/liblayout.so
    /bin/ls: /srv/www/public-html/mod_layout/.libs/liblayout.so: No such file or directory
     
    Last edited: Apr 3, 2006
  8. falko

    falko Super Moderator

    When you do this, can you at least see the footer in the HTML source code?
     
  9. mavgh1

    mavgh1 New Member

    I see nothing

    I don't see anything
    If I search with YAST modules installed in Apache mod_layout doesn't apper.It's normal ?
    I only have in usr/lib/apache2/liblayout.so module installed.
     
    Last edited: Apr 3, 2006
  10. falko

    falko Super Moderator

    How did you install mod_layout? With yast, or manually? In the latter case yast cannot know your mod_layout.
     
  11. mavgh1

    mavgh1 New Member

    it's working

    It's working know
    I have changed

    LoadModule layout_module /usr/lib/apache2/mod_liblayout.so to
    LoadModule layout_module /usr/lib/apache2/mod_layout.so



    Can tell me someone what directives to use to insert a small banner ?
     
  12. falko

    falko Super Moderator

    I've never worked with mod_layout before, but maybe they have some examples/tutorials on the mod_layout web site?
     
  13. miooodek

    miooodek New Member

    Hi, I've got similar problem, when I add to vhost the following line

    Code:
    AddOutputFilterByType LAYOUT text/html
    LayoutFooter footer.html
    
    Nothing appears in WebPage and in error log

    but when I change "LayoutFooter footer.html" to "LayoutFooter somenonexisting.dir" then in log appears that error

    Code:
    [Thu Sep 09 13:01:23 2010] [error] [client 192.168.20.1] The following error occured while processing the Layout : 404
    [Thu Sep 09 16:17:33 2010] [error] [client 192.168.20.1] File does not exist: /var/www/test.qpa/web/somenonexisting.dir
    
    I'm using:
    Debian Lenny
    Apache 2.2
    Mod_Layout 5.1

    Thanks for your time!
     

Share This Page