mod_fcgid problem after migration

Discussion in 'Installation/Configuration' started by Captain, Mar 17, 2015.

  1. Captain

    Captain Member

    Hello!
    I migrate to the new server from 12.04 to 14.04. I installed new server (VM machine) on vmware. I migrated all web pages no new server.
    And now have problem with fcgid. In this example I try to install MODX and give this error
    Code:
    kernel: [286785.700869] php-cgi[24720]: segfault at 16 ip 00000000006fe0d1 sp 00007fffd21e3890 error 4 in php5-cgi[400000+7ee000]
    For example I can not to install MODX for new client:
    Code:
    [Tue Mar 17 21:36:55.986027 2015] [fcgid:warn] [pid 24889] (104)Connection reset by peer: [client 1.1.1.1:52283] mod_fcgid: error reading data from FastCGI server, referer: http://www.domain.com/setup/index.php?action=summary
    [Tue Mar 17 21:36:55.986112 2015] [core:error] [pid 24889] [client 1.1.1.1:52283] End of script output before headers: index.php, referer: http://www.domain.com/setup/index.php?action=summary
    
    Some websites does not work properly:
    to many notice:
    Code:
     mod_fcgid: stderr: PHP Notice:  Undefined variable:
    Web sites does not changed on new server, just migrated.
    Code:
    [email protected]:~# apachectl -V
    Server version: Apache/2.4.7 (Ubuntu)
    Server built:   Mar 10 2015 13:05:59
    Server's Module Magic Number: 20120211:27
    Server loaded:  APR 1.5.1-dev, APR-UTIL 1.5.3
    Compiled using: APR 1.5.1-dev, APR-UTIL 1.5.3
    Architecture:   64-bit
    Server MPM:     prefork
      threaded:     no
        forked:     yes (variable process count)
    Server compiled with....
    -D APR_HAS_SENDFILE
    -D APR_HAS_MMAP
    -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
    -D APR_USE_SYSVSEM_SERIALIZE
    -D APR_USE_PTHREAD_SERIALIZE
    -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
    -D APR_HAS_OTHER_CHILD
    -D AP_HAVE_RELIABLE_PIPED_LOGS
    -D DYNAMIC_MODULE_LIMIT=256
    -D HTTPD_ROOT="/etc/apache2"
    -D SUEXEC_BIN="/usr/lib/apache2/suexec"
    -D DEFAULT_PIDLOG="/var/run/apache2.pid"
    -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
    -D DEFAULT_ERRORLOG="logs/error_log"
    -D AP_TYPES_CONFIG_FILE="mime.types"
    -D SERVER_CONFIG_FILE="apache2.conf"
    
    Code:
    [email protected]:~# php -v
    PHP 5.5.9-1ubuntu4.6 (cli) (built: Feb 13 2015 19:17:11)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
        with XCache v3.1.0, Copyright (c) 2005-2013, by mOo
        with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies
        with XCache Optimizer v3.1.0, Copyright (c) 2005-2013, by mOo
        with XCache Cacher v3.1.0, Copyright (c) 2005-2013, by mOo
        with XCache Coverager v3.1.0, Copyright (c) 2005-2013, by mOo
    
    Some one can help to solve this problem.
     
  2. Captain

    Captain Member

    Problem with MODX solved:
    php.ini
    opcache.enable=0

    But other problem still not solved
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats not a problem with mod_fcgi, this are just the normal logged php notics, fcgi is just prepended because php is running with fcgi. If you dont want php notices to get logged, change the error reporting level in php.ini to supress notices.
     
  4. Captain

    Captain Member

    Thanks Till for answer, yes I now about it. But all this notices is false positive - all variables is defined.
     

Share This Page