mod_fcgid install 2.3.4

Discussion in 'Installation/Configuration' started by myne, Mar 3, 2011.

  1. myne

    myne New Member

    Hello howtoforge,

    I am trying to setup mod_fcgid on version 2.3.4 for research reasons. I have followed the tutorial on the site for getting it setup on ubuntu 10.10 located at the link below and it runs perfect. This install using apt-get installs the 2.3.6 version of the mod_fcgid.

    What I need is to install version 2.3.4 which I can obtain from this location:

    My attempts and what I did...
    I tried to follow the read me and ./configure.apxs, make, install but when I try to a2enmod fcgid I get an error stating "ERROR: Module fcgid does not exist". I go to /usr/lib/apache2/modules/ and see is located in this directory.

    I followed the howtoforge tutorial listed above and when complete I tried 2 things.
    1. ./configure, make, make install the older version
    2. make on a seperate system and replace the file with one from the other server.

    both end up giving me the error "[warn] module fcgid_module is alrady loaded, skipping, [OK] " . From my reading on this error the system thinks there are 2 fcgid_modules running and can not load the one I replaced it with. I get this with both of the #2 attempts.

    If anyone could give me some advice on how to get the mod_fcgid 2.3.4 version working in my test environment or some package that already has this running in it would be of great help.

    Thank you
    Last edited: Mar 3, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    a2enmod works only for modules listed in /etc/apache2/mods-available. Modules that you build yourself have to be added to /etc/apache2/apache2.conf.

Share This Page