Mod_fcgid: can't apply process slot

Discussion in 'Installation/Configuration' started by Hans, Mar 8, 2018.

  1. Hans

    Hans Moderator ISPConfig Developer

    I just migrated a big website from my previous ISPconfig server tot the new one. On the previous server I had no issues with that site but on the new one, I do.

    This keeps repeating in the error.log of the site:

    Mod_fcgid: can't apply process slot for /var/www/php-fcgi-scripts/webxx/.php-fcgi-starter

    But when I add some additional resources in the Apache directive field if that particular site it seems not to have any effect. Where can I add or increase the values for fcgid?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you consider to switch PHP mode to php-fpm? PHP-FPM is basically the successor of php_FCGI and I would use that for larger sites.

    Regarding fcgi settings, If I remember correctly there are two notations, an old one and a new one for each setting, maybe you should try the other notation when you want to keep fcgi. Both are explained on the fcgi module page of the apache documentation if I remember correctly.
     
  3. Hans

    Hans Moderator ISPConfig Developer

    Hi Till,

    I tried PHP-FPM indeed, It was the first thing I did, but then Apache crashes within one hour.

    I studied those fcgi settings entirely. My new server is a new ISPCOnfig 3.1 Debian 9 server with Apache 2.4, which means I have to use the new notation.
    However, nothing happens when I enter new settings for fcgid on the Apache directives field of the website in ISPCOnfig. Not even as a global setting in /etc/apache2/mods-enabled/fcgid.conf.

    So, I don't understand where to change the settings for one particular website.

    *Update*
    In the mean time I switched to PHP-FPM again. I also had to change some configuration stuff of the websites in the web folder. The client runs a WP in /web and also Joomla site in a sub folder. The server does not like that. Now it’s fine again and the server load is low.
     
    Last edited: Mar 10, 2018

Share This Page