Mod tools not working anymore on 3.2dev

Discussion in 'Developers' Forum' started by michelangelo, Feb 28, 2022.

  1. michelangelo

    michelangelo Member

    When I try to open mod tools (labeled as settings in the UI) in 3.2dev, a server error may occure.
    is_admin seems to be not set anymore. This happened on a slightly older ISPConfig 3.2dev snapshot which is maybe 3-4 weeks old.

    Can somebody reproduce this issue?

    Code:
    [Mon Feb 28 10:04:32.778573 2022] [fcgid:warn] [pid 9757:tid 9808] [client 217.227.0.0:25599] mod_fcgid: stderr: #0 /usr/local/ispconfig/interface/web/common.php(48): include_once(), referer: https://cp.XXXXX.net:8088/index.php
    [Mon Feb 28 10:04:32.778578 2022] [fcgid:warn] [pid 9757:tid 9808] [client 217.227.0.0:25599] mod_fcgid: stderr: #1 /usr/local/ispconfig/interface/web/capp.php(60): include_menu_dir_files('/usr/local/ispc...'), referer: https://cp.XXXXX.net:8088/index.php
    [Mon Feb 28 10:04:32.778583 2022] [fcgid:warn] [pid 9757:tid 9808] [client 217.227.0.0:25599] mod_fcgid: stderr: #2 {main}, referer: https://cp.XXXXX.net:8088/index.php
    [Mon Feb 28 10:04:32.778588 2022] [fcgid:warn] [pid 9757:tid 9808] [client 217.227.0.0:25599] mod_fcgid: stderr:   thrown in /usr/local/ispconfig/interface/web/tools/lib/menu.d/resync.menu.php on line 6, referer: https://cp.XXXXX.net:8088/index.php
     
    ahrasis and till like this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    We'll look into that. I can reproduce it here in git-develop branch.
     
    michelangelo likes this.
  3. michelangelo

    michelangelo Member

    Thank you, till
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  5. michelangelo

    michelangelo Member

    Thanks, but Marius fixed it already.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not a full fix, half of the menu is missing. we will have to take a deeper look into the code why it fails now.
     
  7. michelangelo

    michelangelo Member

    You are right.
    I just had noticed that it couldn't be opened anymore and since I barely have a look in this menu I must have seem forgotten that it had a few more submenu entries.
     
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

Share This Page