missing .htpasswd

Discussion in 'Installation/Configuration' started by tonysch, Oct 3, 2006.

  1. tonysch

    tonysch New Member

    I am installing osCommerce on a ubuntu OS with ISPconfig. I am setting my .htaccess for the admin directory in oscommerce. In the past I have added the following to my .htaccess file in the admin folder:

    AuthName "StoreFront Administration Site"
    AuthType Basic
    AuthUserFile /var/www/web1/.htpasswd
    Require valid-user

    When I tried to do this with my latest install the .htpasswd is missing. I did an find for and found nothing.

    could someone help. I must be missing something... :eek:
  2. tonysch

    tonysch New Member

    Could someone please help. I need to get this resolved...

    My .htpasswd files are missing from my install of ISPconfig on Ubuntu. Please..
  3. sjau

    sjau Local Meanie Moderator

    Well, first check whether you put the .htpasswd at the right place. Maybe there's a spelling error in the .htaccess or maybe the .htpasswd file wasn't named according to the .htaccess or it was put into a wrong folder.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check on the shell with the command "ls -la". that the .htpasswd file is really not there. Files that begin with a .dot might be hidden in FTP clients.

    You can add .htpasswd files with the ISPConfig WebFTP client.
  5. sojic

    sojic New Member

    I have also problem with .htpasswd

    I create /var/www/web1/.htpasswd and /var/www/web1/web/.htaccess

    After x time, .htpasswd become empty

    I create this via ssh.
  6. falko

    falko Super Moderator ISPConfig Developer

    You create both files manually, and after some time .htpasswd is empty?

    Is there anything you did before this happened?

Share This Page