Missing configuration files in 3.0.1.4

Discussion in 'Installation/Configuration' started by tssk, Sep 22, 2009.

  1. tssk

    tssk New Member

    Hello,

    yesterday I tried to install ISPC3 on Debian Stable with postfix but I got several error messages. All was about missing files to copy. After some investigation I found out there are no files in ispconfig3_install/config/maildrop and ispconfig3_install/config/postfix .

    Is this OK? (I assume not but I better ask as I am new to the ISPC.)

    If this is bug where should I report it?

    Thank you,

    Tomas Safarik
     
  2. till

    till Super Moderator

    There are no files missing in ISPConfig and there is no such bug known. Especially as ISPConfig never had any files in folders like ispconfig3_install/config/maildrop or ispconfig3_install/config/postfix. I guess you installed ISPConfig wrong.

    Please follow exactly the ispconfig 3 perfect server guide abd make sure that you execute the install.php exactly as described there. It is needed that you enter the install folder with cd and then execute php install.php!
     
  3. tssk

    tssk New Member

    Hello till,

    thanks for you reply.

    I was following step by step installation documentation in ispconfig3_install/docs/INSTALL_DEBIAN_5.0.txt (except for omitting the quota settings but I don't think this should have influence on postfix configuration).

    I did run it exactly this way.

    I wonder why are the folders like ispconfig3_install/config/postfix/ even there if no files belongs to them? Why was I getting errors during installation that PHP is unable to find file and copy it to /etc/postfix/main.cf? (Unfortunatelly I didn't save the messages. But I can run the installation again and see if I can reproduce the problem.) And why postfix is not able to run with "fatal: open /etc/postfix/main.cf: No such file or directory" error message?

    I'll try to find out what I did wrong. So please take my post just like information.

    Thank you

    Tomas Safarik
     
  4. tssk

    tssk New Member

    Hello,

    I did the installation again and the error was:
    Code:
    Warning: copy(/etc/postfix/main.cf): failed to open stream: No such file or directory in /root/ispconfig3_install/install/lib/installer_base.lib.php on line 488
    So I found the problem was that the initial postfix configuration was wrong - missong main.cf file and installation script couldn't modify it. So the problem was on my system not in the ISPConfig.

    So thanks again for your reply.

    Tomas Safarik
     

Share This Page