Mirror servers / unix users not being created on slave

Discussion in 'Installation/Configuration' started by fb23aa, Jul 13, 2014.

  1. fb23aa

    fb23aa New Member

    I made a fresh mirror setup on 2 Debian 7 servers. All seem to work fine, database replication works fine, except that the slave server doesn't get unix users created when creating a new website on master, therefore unison can't replicate user owned folders to the slave.
    Did I miss something on the setup?

    Thanks in advance for your help!
  2. srijan

    srijan New Member HowtoForge Supporter

    How did you created the mirror setup?
    It might be posible that you missed something there
  3. fb23aa

    fb23aa New Member

    I followed carefully the instructions on the ispconfig manual, and on this guide: http://www.howtoforge.com/installin...tabase-cluster-on-debian-6.0-with-ispconfig-3

    Everything seems to be setup properly, both servers are available on ispconfig interface on master, I configured the salve to be mirror of master, but when I create a client then a website, the corresponding unix user is created on master but not on slave, therefore unison, which has been configured to preserve ownership of the files, cannot copy the client's files to slave...

    I am a bit stuck here..
  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. fb23aa

    fb23aa New Member

    I found my mistake. Turns out somehow I forgot to change the default shell on the slave server when installing Debian.

    Reinstalled everything, and now ispconfig is replicating unix users perfectly :)

    Thanks guys!

Share This Page