Mirror Server not Syncing

Discussion in 'Installation/Configuration' started by mjjazz, Oct 7, 2013.

  1. mjjazz

    mjjazz New Member

    I think I blew it on August 12, 2013. I believe that is the day when I upgraded to ISPConfig 3.0.5.3 on my mirror server and my master server. Since that time, according to timestamps in the dns_rr table, my DNS on the mirror server has not updated.

    I am running Ubuntu 12.04.3 LTS with Apache2, php 5.3.10, mysql 5.5.32.

    I have set my loglevel on the master server to DEBUG and manually run the server.sh, but I do not see any errors. In fact the only output is to set a lock and remove the lock.

    I am thinking that I answered the reset permissions questions wrong in one or both of the upgrades, so how do I make sure the permissions for both my slave and master are correct?

    If permissions are not the issue, what do I need to do to find out why the remote ISPConfig database is not updating? What do I need to do to bring it back into sync with the master?

    Thank you,

    --MPJ
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    enable debugging for the slave server on the master and run the server.sh script on the slave and post the output.
     
  3. mjjazz

    mjjazz New Member

    OUCH!

    (11 times): PHP Warning: mysqli::mysqli(): (HY000/1129): Host 'dmz03fw.halff.ad' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts' in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 62
    DB::__construct Host 'dmz03fw.halff.ad' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'

    PHP Warning: mysqli::close(): Couldn't fetch db in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 82


    I performed the flush-hosts command on the slave and re-ran the server.sh to get the same results.

    --MPJ
     
  4. mjjazz

    mjjazz New Member

    I apologize for being impatient, but I need to know if I just need to build a new mirror server, build a whole new set of servers, or is there some other easy fix? My remote server has not synced with the master since August 12 when I performed the upgrade to ISPConfig 3.0.5.3. The error from server.sh on the remote is:

    PHP Warning: mysqli::mysqli(): (HY000/1129): Host 'dmz03fw.halff.ad' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts' in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 62
    DB::__construct Host 'dmz03fw.halff.ad' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'

    PHP Warning: mysqli::close(): Couldn't fetch db in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 82​

    The master server shows no errors when manually running server.sh.

    Any ideas?

    Thank you,

    --MPJ
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Your problem is that the slave server tries to connect to the master with a wrong user or password, this causes the amster to block further connections from the slave.

    run mysqladmin flush-hosts on the master. Then rerun the ispconfig update on the slave and select to reconfigure permissions in master database.
     
  6. mjjazz

    mjjazz New Member

    OK, that is a reasonable procedure, but how do you force the update script to run when you are already at the latest version? I'm getting "There are no updates available for ISPConfig 3.0.5.3", and it exits.

    --MPJ
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Download ispconfig, unpack it and run the update.php script in the install folder.
     
  8. mjjazz

    mjjazz New Member

    Thanks till!

    On the slave, I actually ran:

    /usr/local/ispconfig/server/scripts/update_from_tgz.sh​

    Then tested with:

    /usr/local/ispconfig/server/server.sh​

    Which gave me an [email protected] mysql access error. With that I copied the password out of /usr/local/ispconfig/server/lib/config.inc.php and pasted it into the privileges of the ispconfig user on the slave using phpmyadmin (and of course flush privileges).

    Server.sh stopped showing errors, but then the syncing of the changes during the outage had to be forced from the ISPConfig web interface on the slave.

    I hope this helps someone else in the future. All is well now. Thanks again till!



    --MPJ
     

Share This Page