Mingetty respawns too fast ... can't see errors!

Discussion in 'Technical' started by leitner, Feb 15, 2009.

  1. leitner

    leitner New Member

    When I sign on in runlevel 3, two lines flash quickly, then mingetty respawns with my login prompt again. Problem is: I can't see the messages, they're gone too quickly. The first line has the words "last login" in it, and I think the second says something about "no shell", but I'm not certain. The "/etc/passwd" file shows me using "/bin/bash", as I would expect.

    I noticed that way back in RedHat 9, someone complained about this, but it was either NOT considered a bug, or considered of low priority, since the admin could see the errors in the log.

    But where is this log? I looked in /var/log/ and didn't see anything close!

    How can I find out what these messages say in order to troubleshoot? I'm using Fedora 10, so mingetty is not controlled by /etc/inittab.

    Thanks ... Rich Leitner
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you see any errors in the output of
    Code:
    dmesg
    ?
     
  3. leitner

    leitner New Member

    No ... I was unfamiliar with this command but I'll be educating myself posthaste. There is a great deal of output, but no obvious errors. The only line with 'error' in it was
    Code:
     end_request: I/O error dev sr0 sector 15863380
    and I think that this refers to my CD-ROM or some other device not associated with my specific problem.

    To be honest, I posted this because I was hoping to solve my RAID sign in problem, but your post in that thread to disable SELinux appears to have solved it.

    I'm still curious as to if and where mingetty writes errors to a log file, if anyone could help me out.

    Rich
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Is this maybe a problem with your hard drive?
     
  5. leitner

    leitner New Member

    I googled this error message, and there were a number of hits: It seems that this is a fairly common message, though none of the cases appeared to be relevant to mine. All dealt with some type of problem with a CD/DVD drive. My hard drives appear to be working normally.

    Again, this rapid respawn of mingetty seemed to simply disappear when I disabled SELinux, which I did based on your post in my RAID HowTo thread. I'm not a big expert on any part of Linux, but SELinux is a particularly large abyss in my knowledge base. I'm curious to learn more eventually, but on virtually all of my Linux machines I have it disabled: I can't figure out why I need this extra layer of protection and it's bitten me several times when I'm trying to get something working! As soon as I disabled it on this machine and rebooted, everything worked fine.

    Several 'google hits' led me to believe that mingetty would log all its errors in /var/logs/mgetty.log or some similarly named file; no such obviously named files in my setup. And perhaps there were NO error messages, it flashed too fast for me to see. That might explain why 'dmesg' also did not show any relevant error messages.
     

Share This Page