Ming and PHP5

Discussion in 'Installation/Configuration' started by P Lao, Nov 7, 2006.

  1. P Lao

    P Lao New Member


    I would like to use Ming with php5, and I have some problems...

    I installed the debian packages:
    ii php5-ming 5.2.0-0.dotdeb Ming module for php5
    ii libming 0.3-0.dotdeb.0 Library to generate SWF (Flash) Files

    in my php.in I have: extension=ming.so (done at the intallation of php5_ming)

    when I restart apache2 I get:
    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/ming.so' - libming.so: cannot open shared object file:
    No such file or directory in Unknown on line 0

    and the libraries are here :
    ls -al /usr/lib/php5/20060613/*ming.so
    -rwxr-xr-x 1 root root 1003279 2006-11-06 18:11 /usr/lib/php5/20060613/libming.so
    -rw-r--r-- 1 root root 99036 2006-11-04 00:06 /usr/lib/php5/20060613/ming.so

    I have seen this error in a few messages on the web, but I didn't find the answer...

    I was wondering is there was a problem with the package but I have seen in the tutorial "Running Apache2 With PHP5 And PHP4 At The Same Time" that there is an installation of php5_ming, so I suppose I shoud work...

    It is the first time that I have this kind of problem with a php5 package. I am trying to sort it out since yesterday morning but don't understand....

    Thanks very much in advance for any idea ...

  2. P Lao

    P Lao New Member

    ..and I tried this as well...

    PHP5 is installed as a module of apache2

    anyway I saw this page

    so I did
    apt-file search ming.so

    apache-common: usr/lib/apache/1.3/mod_roaming.so
    ethereal-common: usr/lib/ethereal/plugins/0.10.10/cosnaming.so
    liborbit-dev: usr/lib/libORBitCosNaming.so
    liborbit0: usr/lib/libORBitCosNaming.so.0
    liborbit0: usr/lib/libORBitCosNaming.so.0.5.17
    libtao-orbsvcs-dev: usr/lib/libTAO_CosNaming.so
    libtao-orbsvcs1.4: usr/lib/libTAO_CosNaming.so.1.4.2
    neverdata: usr/share/games/neverdata/map-putt/17_timing.sol
    python2.1: usr/lib/python2.1/lib-dynload/timing.so
    python2.2: usr/lib/python2.2/lib-dynload/timing.so
    python2.3: usr/lib/python2.3/lib-dynload/timing.so
    python2.4: usr/lib/python2.4/lib-dynload/timing.so
    python2.4-dbg: usr/lib/debug/usr/lib/python2.4/lib-dynload/timing.so
    python2.4-dbg: usr/lib/python2.4/lib-dynload/debug/timing.so
    simgear-dev: usr/lib/libsgtiming.so
    simgear0: usr/lib/libsgtiming.so.0
    simgear0: usr/lib/libsgtiming.so.0.3.7

    so no ming.so: is this information relevant?

    and when I comment out extension=ming.so in php.ini the error disappears so I am using the right php.ini

  3. P Lao

    P Lao New Member


    when I did apt-file update
    before apt-file search ming.so
    I got an error 404 for dotdeb so this is why the ming.so doesn't show I think (I have it in /usr/lib/php5/20060613/ anyway)

    OK I think this is all the information I have about my problem...

    Any suggestion would be most welcome, thanks in advance...

  4. P Lao

    P Lao New Member

    Solution: This is a problem with a dotdeb package

    Once again I am answering my own message...sorry...but this one can be VERY usefull I think, I have seen so much messages about ming not working with php5...

    So if you want to use PHP5.2.0-0.dotdeb (and cie, maybe...) and Ming and you have this error:

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/ming.so' - libming.so: cannot open shared object file: No such file or directory in Unknown on line 0

    Then go to /usr/lib and look for libming.so*
    you will have something like
    lrwxrwxrwx 1 root root 19 2006-11-07 17:13 libming.so.0 -> libming.so.0.3beta1
    -rw-r--r-- 1 root root 270224 2005-06-17 06:52 libming.so.0.3beta1

    but not libming .so

    so just add the link: ln -s libming.so.0.3beta1 libming.so

    and it works.....

    ...2 days for that one....end of thread :)

Share This Page