MIME error: unexpected end of preamble

Discussion in 'Server Operation' started by pto44128, Aug 14, 2008.

  1. pto44128

    pto44128 New Member

    My SUSE/Postfix/Cyrus email server continues to run great. Incoming messages with header errors are routed to my spam mailbox. I have been seeing more and more emails in the spam mailbox with this error... BAD HEADER MIME error:unexpected end of preamble...
    When I go in and view the message source, I can see someting like this in the header ...
    Content-Type: multipart/alternative;

    In the message body itself I see this
    This is a multi-part message in MIME format.

    As I understand things, the MIME parser is looking for the boundry marker as defined in the header. When it doesn't find it in the body of the message, it generates an error. I looked at "good" messages and this seems to be the case. The boundry marker is consistant throughout the entire message. Some of these messages with this error are actually things that need to be delivered. The only common thing I found with all the "problem" messages is this line in the header...
    x-mimeole: Produced By Microsoft Exchange V6.5

    Is this version of Exchange violating the MIME format?
    Is there a way to work around this problem??
    Once the MIME parser "reads" the message , it is damaged. The body and attachments are stripped off. All that is left is the header, and a blank message. Am I missing something?? Am I even looking in the right place??

    Thanks in advance

Share This Page