Migtool SOURCE mail dir wrong in rsync command

Discussion in 'Plugins/Modules/Addons' started by Taleman, Oct 16, 2017.

  1. Taleman

    Taleman Member

    Running Migration Tool version 1.6.12, downloaded today. Still the same bug that as been in all versions I have tried, namely in the generated command file the rsync commands have wrong source argument.
    On my SOURCE server the mail directories are in /home/vmail. I write this as answer to migtool question but still in the generated rsync commands the source argument is /var/vmail.
    My fix is to find an expression that matches only those problem rsync lines and do global replace to the correct text.
     
  2. HSorgYves

    HSorgYves Active Member

    Create a symlink from /var/vmail to /home/vmail
     
  3. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    This is not a bug in the migration tool, it just supports a standard path for now and does not allow other paths to be entered. This will be different in the upcoming completely reworked migration tool 2.0

    The easiest to work around this at the moment is using "sed" or "replace" to modify the bash script that is generated.
     

Share This Page