Migration Toolkit problem

Discussion in 'Plugins/Modules/Addons' started by unsichtbare, Aug 31, 2019.

  1. unsichtbare

    unsichtbare Member HowtoForge Supporter

    Howdy! I used the Migration Toolkit successfully (very!!) to migrate an ISPConfig 3 from Ubuntu 16.04 to ISPConfig 3 18.04, but am now attempting to migrate a much older server (Ubuntu 12.04) to the same 18.04, the point being to consolidate on a single, modern server.
    When I run .migrate in the 16.04 box, I get:
    Code:
    [email protected]:~/migration# ./migrate
    ionCube already active in PHP.
    
    Fatal error: The file /root/migration/v53/migrate.php cannot be decoded
    by this version of the ionCube Loader.
     If you are the administrator of this site
    then please install the latest version of the ionCube Loader.
     in Unknown on line 0
    Code:
    PHP 5.3.10-1ubuntu3.9 with Suhosin-Patch (cli) (built: Dec 12 2013 04:27:25)
    Copyright (c) 1997-2012 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
        with the ionCube PHP Loader v4.2.2, Copyright (c) 2002-2012, by ionCube Ltd., and
        with XCache v1.3.2, Copyright (c) 2005-2011, by mOo
    I tried a new installation of ionCube using these directions: https://www.howtoforge.com/tutorial/how-to-install-ioncube-loader/
    but it basically broke the system and Apache wouldn't start.
    Any ideas?
    THX
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Did you mean 12.04?
    Is the old ubuntu 32-bit? Check with
    Code:
    dpkg --print-architecture
    I remember from my migration that ioncube did not work on 32-bit by default. I do not remember exacly, but i think I needed to install the special version manually.
    https://www.howtoforge.com/community/threads/migration-tool-error.74709/
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The Migration tool needs ioncube for PHP cli. Try installing it for cli only so it will not affect apache.
     
    Croydon likes this.

Share This Page