Migration Tool - Missing OpenSSL

Discussion in 'ISPConfig 3 Priority Support' started by mphayesuk, Mar 14, 2018.

  1. mphayesuk

    mphayesuk Member HowtoForge Supporter

    Hi all, I am running Debian 6 with ISPConfig v3 and I have a new setup on Debian 9 with ISPConfig 3.1.11.

    I want to run the migraiton tool but when I try and run it I get the following error.

    Your PHP installation is missing openSSL support. Please activate openSSL module

    I am guessing I need to add this line to my php.ini file:
    extension=php_openssl.so

    My question is which php.ini file do I need to edit?
    /etc/php5/apache2/php.ini
    /etc/php5/cgi/php.ini
    /etc/php5/cli/php.ini
    /opt/phpfcgi-5.6.31/lib.php.ini
    /opt/phpfcgi-5.6.31/lib/php.ini

    Will this cause any issues to any running web sites, no clients websites apart from the ISPConfig admin UI uses SSL.

    Thanks
     
  2. Taleman

    Taleman Active Member HowtoForge Supporter

    I have not seen that error when using migration tool. Is openssl installed?
     
    Last edited: Mar 14, 2018
  3. mphayesuk

    mphayesuk Member HowtoForge Supporter

    Interesting question and the answer is no. I ran php -m and openssl is not in the list. OpenSSL is installed on the OS.

    Whats the process to get this resolved?

    Thanks
    Martin
     
  4. Taleman

    Taleman Active Member HowtoForge Supporter

  5. mphayesuk

    mphayesuk Member HowtoForge Supporter

    I have been doing some investigating and found that even thought php is running in apache is looks like php cli is not running correctly.

    I ran this from the OS cli -
    php --ini
    Configuration File (php.ini) Path: /usr/local/lib
    Loaded Configuration File: (none)
    Scan for additional .ini files in: (none)
    Additional .ini files parsed: (none)
     
  6. mphayesuk

    mphayesuk Member HowtoForge Supporter

    OpenSSL is enabled for the apache, phpinfo() returned the following
    openssl
    OpenSSL support enabled
    OpenSSL Library Version OpenSSL 0.9.8o 01 Jun 2010
    OpenSSL Header Version OpenSSL 0.9.8o 01 Jun 2010

    So I think its just PHP CLI that has an issue.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    please run:

    which php

    and post the result. It might be that you accidently replaced the shell php binary with a custom compiled one without openssl support.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    please run:

    which php

    and post the result. It might be that you accidently replaced the shell php binary with a custom compiled one without openssl support.
     
  9. mphayesuk

    mphayesuk Member HowtoForge Supporter

    /usr/local/bin/php
     
  10. mphayesuk

    mphayesuk Member HowtoForge Supporter

    When I run php -m from /usr/local/bin/php I get the following, no openssl, how can I fix this?

    [PHP Modules]
    Core
    ctype
    date
    dom
    ereg
    fileinfo
    filter
    hash
    iconv
    json
    libxml
    pcre
    PDO
    pdo_sqlite
    Phar
    posix
    Reflection
    session
    SimpleXML
    SPL
    sqlite3
    standard
    tokenizer
    xml
    xmlreader
    xmlwriter

    [Zend Modules]
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    That's wha I guessed. Run:

    mv /usr/local/bin/php /usr/local/bin/php_bak

    and then run the migration tool again.
     
  12. Taleman

    Taleman Active Member HowtoForge Supporter

    The stock debian php is /usr/bin/php, so that /usr/local/bin/php is from somewhere else, probably the one you installed.
    You need to configure PHP so that the normal Debian PHP is run for command line. Undo the changes done to get the extra php as default.
     
  13. mphayesuk

    mphayesuk Member HowtoForge Supporter

    Thanks Till/Taleman for your support, the mv command did the trick and the migration tool is now working.

    Thanks again.
     

Share This Page