Migration problems

Discussion in 'Installation/Configuration' started by crypted, Jan 27, 2008.

  1. crypted

    crypted New Member

    1) ProFTPD will not start.
    Code:
    [[email protected] mod_auth_pam]# /etc/init.d/proftpd start
    Starting proftpd:  - Fatal: unknown configuration directive 'AuthPAMConfig' on line 20 of '/etc/proftpd.conf'
    [FAILED]
    [[email protected] mod_auth_pam]# 
     
    Last edited: Jan 27, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the complete proftpd.conf file.

    1) Which linux distribution do you use?
    2) Is this a proftpd pacake from the distribution or did you compile it manually?
     
  3. crypted

    crypted New Member

    CENTOS 5.1 and I believe it was an RPM installed through the Perfect Installation notes on the website.


    Also, NAMED doesn't seem to be working right on the new box. I can't get domains to resolve. (the IP is 65.110.53.130 and some domains are inter5.org, kissland.com, areyouliberal.com, and schlechthatchery.com)

    named 20254 0.1 0.3 37736 3820 ? Ssl 09:11 0:26 /usr/sbin/named -u named -t /var/named/chroot

    The setup configuration on ISPCONFIG's web interface for DNS has this:
    named.conf - /etc/named.conf
    zonefiles dir - /home/admispconfig/ispconfig/web/multidoc/edit


    NAMED.CONF starts out as:
    Code:
    options {
            pid-file "/var/named/chroot/var/run/named/named.pid";
            directory "/home/admispconfig/ispconfig/web/multidoc/edit";
            auth-nxdomain no;
    };
    zone "." {
            type hint;
            file "named.root";
    };
    
    zone "0.0.127.in-addr.arpa" {
            type master;
            file "named.local";
    };
    
    zone "53.110.65.in-addr.arpa" {
            type master;
            file "pri.53.110.65.in-addr.arpa";
    };
    zone "163.150.207.in-addr.arpa" {
            type master;
            file "pri.163.150.207.in-addr.arpa";
    };
    
    zone "kissland.com" {
            type master;
            file "pri.kissland.com";
    };
    zone "der
    ...........................
    
    Also, there are tons of messages in /var/log/messages pertaining to all of the domains. Here's a sample:
    Code:
    Jan 28 15:40:31 inter5 named[20254]: lame server resolving 'andovermeat.com' (in 'andovermeat.com'?): 65.110.53.138#53
    Jan 28 15:40:31 inter5 named[20254]: lame server resolving 'andovermeat.com' (in 'andovermeat.com'?): 65.110.53.131#53
    Jan 28 15:40:31 inter5 named[20254]: lame server resolving 'andovermeat.com' (in 'andovermeat.com'?): 65.110.53.138#53
    Jan 28 15:40:31 inter5 named[20254]: lame server resolving 'andovermeat.com' (in 'andovermeat.com'?): 65.110.53.130#53
    Jan 28 15:40:31 inter5 named[20254]: lame server resolving 
    It appears as though NAMED isn't taking an authoritative stance. I changed /etc/resolv.conf to have only my IPs in there, still no fix. I also added some information to the named.conf and still no go...

    Code:
    include "/etc/rndc.key";
    
    controls {
            inet 127.0.0.1 allow { localhost; } keys { "rndc-key"; };
    };
    
    acl trusted { 127.0.0.1; 66.111.32.57; 66.111.32.58; };
    
    options {
            allow-recursion {trusted;};
            allow-transfer {trusted;};
    };
    
    options {
            pid-file "/var/named/chroot/var/run/named/named.pid";
            directory "/home/admispconfig/ispconfig/web/multidoc/edit";
            auth-nxdomain no;
    };
    Code:
     dig inter5.org
    ;; Warning: ID mismatch: expected ID 17899, got 30893
    ;; Warning: ID mismatch: expected ID 17899, got 30893
    ;; Warning: ID mismatch: expected ID 17899, got 30893
    
    ; <<>> DiG 9.3.3rc2 <<>> inter5.org
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 17899
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;inter5.org.                    IN      A
    
    ;; Query time: 1369 msec
    ;; SERVER: 65.110.53.130#53(65.110.53.130)
    ;; WHEN: Mon Jan 28 19:08:55 2008
    ;; MSG SIZE  rcvd: 28
     
    Last edited: Jan 29, 2008
  4. crypted

    crypted New Member

    I got it working by doing removing the CHROOT from the named server.
    This means I have to execute it manually by typing

    Code:
    /sbin/named -u named
    Is there a way to get this to work in a CHROOT environment? Is the CHROOT environment required?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes.

    No, but recommended.

    Your problem is that the permissions of your bind config directories are wrong.

    1) Change the permissions of the bind config directories as described in the perfect setup guide.
    2) Set the correct path to the bind config file directory in ispconfig under management > server > settings.
     
  6. crypted

    crypted New Member

    I redid all of the steps just in case from the Perfect Setup, there were no errors in doing so. I also verified the correct path to the zone files. Everything is setup correctly and NAMED still will not work in the CHROOTed environment. Ideas?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Are you absolutely sure you've used the exact commands from the Perfect Setup? Maybe you've made a typo or something...
     
  8. crypted

    crypted New Member

    Yes I did the exact commands. The way to fix it was to move the /etc/named.conf to the /var/named/chroot/etc/ directory. After doing so it functioned properly.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    After you moved the file, you should make a symlink from /etc/named.conf to /var/named/chroot/etc/named.conf
     
  10. crypted

    crypted New Member

    It's working fine as is, but just incase, I will make that symlink Till. Thanks a lot guys! Great job with ISPConfig!
     

Share This Page