Migration from ISPConfig3 Apache to ISPConfig3 nginx?

Discussion in 'Installation/Configuration' started by zenny, Dec 3, 2013.

  1. zenny

    zenny Member


    I am trying to migrate a working ISPConfig3 apache installation to ISPConfig3 nginx installation in a different server. The ISPConfig3 apache server is hosting a few domains.

    What is the ideal way of migrating the hosted domains and DNS without breaking ISPConfig3? Or do I have to migrate one by one manually?

    Appreciate your inputs and experiences. Thanks!
  2. zenny

    zenny Member

    So far, what I have done is:

    §1. backed up /var/www directory from old server
    §2. backed up mysql db from old server
    §3. Extracted the §1 into the /var/www in the new server
    §4. Inserted §2 to the new server
    §5. Logged in to the ISPConfig3 panel of the new server with the admin password of the old server
    §6. Resync'ed everything from Tools>Resync
    §6A. Enabled SNI to one of the sites.
    §7. And then the webpanel and all other sites went down. Tried to access the ISPconfig3 panel as admin with password that is working in §5 a few seconds ago , outputting "Username or Password empty." error message.
    §8 When I checked the relevant host files in /etc/nginx/sites-available, all vhosts files are renamed with a .err suffix while the vhost files only have the following lines:
    Last edited: Dec 3, 2013
  3. zenny

    zenny Member


    What I did was:

    §1 #grep db_password /usr/local/ispconfig/server/lib/config.inc.php
    §2 noted the password and started mysql as root and changed the password:
    mysql>SET PASSWORD FOR 'ispconfig'@'localhost' = PASSWORD('abcd12345');

    §3 The above let admin in to the ISPConfig3 panel, but 'Logout' and 'Search' fields are missing on the top right of the header frame of ISPConfig3 panel.

    §4 when I checked mysql status, it output:
    §5. Then I tried to access mysql as admin with:

    #mysql -u debian-sys-maint -p

    with the password from the following command:

    [/QUOTE]# cat /etc/mysql/debian.cnf
    # Automatically generated for Debian scripts. DO NOT TOUCH!
    host = localhost
    user = debian-sys-maint
    password = ALongString
    socket = /var/run/mysqld/mysqld.sock
    host = localhost
    user = debian-sys-maint
    password = ALongString
    socket = /var/run/mysqld/mysqld.sock
    basedir = /usr [/QUOTE]

    It showed up an error:
    There is nothing in /var/log/mysql.log and mysql.err!

    Any inputs?
    Last edited: Dec 3, 2013
  4. zenny

    zenny Member

    I reinstalled from source ISPConfig3 and the admin panel seems to work (the logout and search reappered.

    But the sites are not rendered even after resyncing. It fails to create SSL certificates in the SSL tab.

    It seems to be related with the §5 in my previous post, I guess.

    Any hints? Thanks!

Share This Page