Migration between Virtual Email and ISPConfig

Discussion in 'Installation/Configuration' started by xyhfna, Feb 9, 2007.

  1. xyhfna

    xyhfna New Member

    I recently managed to get ISPconfig up and running using 2.2.8 (2.2.9 didnt work as detailed in another query).

    My setup is based on the "The Perfect Setup - Debian Sarge (3.1)" guide, after which i installed a virtual user/email server based on the "Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)".

    This setup worked well, and i was able to send and receive messages from the server. Sent/Received messages were verified by having sender/receiver as one of the known users in the data base. The server also performed authentication.

    I recently decided to use ISPconfig on the server, and after a few false starts, and a change of version i managed to get ISPconfig working. I have domains populating the DNS (i dont actually use the server as a name server, i host my DNS elsewhere, but are set up correctly!). I have users and resellers, etc all populating ISPconfig.

    However, i am neither able to access the server to send or receive mail as the server rejects all mail with messages similar to the one below:

    Feb 9 14:18:44 cobalaa1 postfix/smtpd[2072]: NOQUEUE: reject: RCPT from virtual host[]: 554 <dummy @i-deation.net>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<localhost>

    It doesnt seem to be checking the tables correctly, and so neither the original virtual user email works nor the new ISPconfig email.

    All the postfix .cf files, etc seem to be the same as before (i.e. as when email was working!).

    I cant work out what the problem is. Anyone any ideas?

    PS: i noticed in the log the email addresses have a space in them now (these spaces are not present when the messages are sent!)
    Last edited: Feb 9, 2007
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    You seem to be sending an email to an addres with a space in it
    dummy @i-deation.net
    That's an illegal address.
  3. xyhfna

    xyhfna New Member

    As i explained in the post script I am not sending to an illegal domain. I put in '[email protected]' and somehow the system generated both the email address 'dummy @i-deation.net' and '[email protected]'. I had nothing to do with it! After a reboot i havent found a repeat of the spacing incident, so that bit must have been fixed at reboot.

    I am still experiencing the same difficulty (all email is rejected, except mail sent to a local user listed in the original virtual user database). Previously i could log in and send messages from a local user to anyone anywhere, but now i cant.

    I can log in to the server locally or externally (so thats not broken!)
    i.e. "telnet myserver 25" from my desktop (external)
    "telnet localhost 25" from myserver (local)

    I can send to users on the original virtual user database

    I cannot send to an ISPconfig user
    I cannot send from ANY user to an external email address

    hopefully that clears up a few thing for you.
  4. xyhfna

    xyhfna New Member

    I have reverted back to just using the "Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)" setup, and I am using apache2 virtual host configurations (with the site structure as was set up in ISPconfig, before i removed ISPconfig). OK, so i cant 'host' sites with their own control panel, etc. But my email works again!

    Is it possible to get a similar virtual user setup inside ISPconfig without using postfix hash tables/plain text files? I cant see why not since they both use postfix (and other apps) in the same way.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    No, at least not with the currect ISPConfig version.
  6. xyhfna

    xyhfna New Member

    Having reverted back to the Virtual Email with Postfix, i find that external MTAs are unable to send messages to my server. the mx in the DNS works fine as mail is being relayed to my MTA, but is getting rejected for some reason. I have looked through the verbose logs (i enabled verbose logging so that i can see where things are going wrong). The server is going through normal checks, the remote MTA is not (obviously) one of my trusted networks (as it only trusts the local network). The remote MTA doesnt know how to log in with the correct authorisation (obviously) so fails the sasl authentication. The last check from what i gather is the reject_unauth_destination check, which should check to see if the recipient is valid and this last check also seems to fail, but i cant understand why as the recipient is valid (and is receiving mail if posted on the local server, or validated with sasl). The mail is queued, but ultimatly fails with the immortal line line "connect to[]: Connection refused (port 10024)". Any ideas?

    Have attached main.cf, master.cf and mail.log as an archive if any of it helps. [REMOVED]
    {I sorted part of the problem, see below, so i removed the archive as it is no longer relevant}

    many thanks
    Last edited: Feb 16, 2007
  7. xyhfna

    xyhfna New Member

    Turned AMVIS off and also found a config setting for not receiving mail from unknown addresses. Have double/triple checked settings, and find that something in amvis is stopping delivery. Mail delivery works fine without amvis (now i've turned of the config setting above). any advice, or am i going to have to post this elsewhere since its an amvis problem (no longer related to ISPConfig)
  8. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
  9. xyhfna

    xyhfna New Member

    not since turning amvis off, every time it is enabled i get the 'connect to[]: Connection refused (port 10024)' error message, as well as all sorts of messages about no matches, etc (which are to be expected when logging in verbose mode). It is the amvis issue i find most unfortunate as i would like for all mail that originates from or is received by a known user to be filtered through amvis before delivery, neither of which can happen at the current time.

    if it would help i can reactivate amvis and generate a test log, but i'm not sure what help it would be.
  10. falko

    falko Super Moderator ISPConfig Developer

    That looks as if amavisd isn't running. Maybe you have syntax errors in the amavisd configuration file?
  11. xyhfna

    xyhfna New Member

    yeah, i just checked and amavisd wasnt running, dont know how it got turned off... still got to check the start-up settings, but tried to send from a remote server to one of the virtual mailboxes and the server handled it fine. I think that solves the issues i ve been having for now. Many thanks for the help you guys.

Share This Page