Migrate server A to server B problem

Discussion in 'Installation/Configuration' started by Gimly, Sep 11, 2007.

  1. Gimly

    Gimly Member

    Hi ISPConfig team,

    I have migrate server A to server B (Server B was installing with the perfect debian etch setup with ispconfig 2.2.16), but I have two problem :

    1) My server can't receive e-mail, when I look /var/log/mail.log, I have this :

    2) I have problem for restart mysql :

    I've search on google with no result ... If you are an answer about this ?

    Thank you for your help :)
     
    Last edited: Sep 11, 2007
  2. Gimly

    Gimly Member

    No answers ? :(
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    What exactly did you move to the new server? It looks as if you have overridden the mysql system tables and the /var/log directory.
     
  4. Gimly

    Gimly Member

  5. falko

    falko Super Moderator ISPConfig Developer

  6. Gimly

    Gimly Member

    I reinstall postfix and move my backup of server A to B with your directive in the other post and now I have this error :

    Code:
    Sep 12 21:24:20 cronos postfix/cleanup[22751]: fatal: trace: remove 50B1710091 log: Permission denied
    Sep 12 21:24:21 cronos postfix/pickup[21549]: warning: premature end-of-input on public/cleanup socket while reading input attribute name
    Sep 12 21:24:21 cronos postfix/master[21547]: warning: process /usr/lib/postfix/cleanup pid 22751 exit status 1
    Sep 12 21:24:21 cronos postfix/master[21547]: warning: /usr/lib/postfix/cleanup: bad command startup -- throttling
    Sep 12 21:24:21 cronos postfix/cleanup[22752]: fatal: trace: remove 53CAA10091 log: Permission denied
    Sep 12 21:24:22 cronos postfix/pickup[21549]: warning: premature end-of-input on public/cleanup socket while reading input attribute name
    Sep 12 21:24:22 cronos postfix/master[21547]: warning: process /usr/lib/postfix/cleanup pid 22752 exit status 1
    Sep 12 21:25:01 cronos postfix/anvil[22681]: statistics: max connection rate 1/60s for (smtp:80.12.242.97) at Sep 12 21:23:15
    Sep 12 21:25:01 cronos postfix/anvil[22681]: statistics: max connection count 1 for (smtp:80.12.242.97) at Sep 12 21:23:15
    Sep 12 21:25:01 cronos postfix/anvil[22681]: statistics: max cache size 1 at Sep 12 21:23:15
    Sep 12 21:25:21 cronos postfix/cleanup[22823]: fatal: trace: remove 8BD7710091 log: Permission denied
    Sep 12 21:25:22 cronos postfix/pickup[21549]: warning: premature end-of-input on public/cleanup socket while reading input attribute name
    Sep 12 21:25:22 cronos postfix/master[21547]: warning: process /usr/lib/postfix/cleanup pid 22823 exit status 1
    I've search on postfix website, but no answer ... :(
    I think, i will send e-mail on mailing list support postfix.
    Or if you have an other idea ... thank you :)
     
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in your /etc/postfix/main.cf?
     
  8. Gimly

    Gimly Member

    There are :

    Thank you :)
     
    Last edited: Sep 17, 2007
  9. falko

    falko Super Moderator ISPConfig Developer

    Looks good.

    It seems to be some permission problem. Have you tried to reboot the system?
     
  10. Gimly

    Gimly Member

    No, :eek:

    Ok reboot it and I test. :eek: :eek:
     
  11. Gimly

    Gimly Member

    The problem persist ... I think I send e-mail to postfix support.
     
    Last edited: Sep 17, 2007
  12. Gimly

    Gimly Member

    Hi all,

    I think the problem become to MX records, because when I test with this website : http://www.mxtoolbox.com/ with the domain www.espace4you.org, the website doesn't found the mx record.

    This is my configuration for the domain :

    [​IMG]

    [​IMG]

    Can you correct me about it if it's false ?

    Thank you for your help :)
     
  13. falko

    falko Super Moderator ISPConfig Developer

    This is what I'm getting now:

    Code:
    mh1:~# dig mx espace4you.org
    
    ; <<>> DiG 9.2.1 <<>> mx espace4you.org
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27619
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;espace4you.org.                        IN      MX
    
    ;; ANSWER SECTION:
    espace4you.org.         86400   IN      MX      10 cronos.espace4you.org.
    
    ;; ADDITIONAL SECTION:
    cronos.espace4you.org.  86400   IN      A       91.121.78.119
    
    ;; Query time: 132 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Fri Sep 21 17:45:49 2007
    ;; MSG SIZE  rcvd: 71
    
    mh1:~#
    Looks ok.
     
  14. Gimly

    Gimly Member

    After more and more research on google, I've found the solution :

    then this command, for php can send e-mail

    and it work very fine :D

    But if anyone have a solution for this problem :


    Thank you :)
     
    Last edited: Sep 24, 2007
  15. 2ndmouse

    2ndmouse New Member

    Check your mysql db - for debian maint with no rights - delete it
     
  16. Gimly

    Gimly Member

    Ok thank you :)
     
  17. tester321

    tester321 Member

    Thank you for this!!

    Thank you. This tip and some additional googling helped me figure it out.

    FWIW, the key error I was getting in /var/log/mail.err was:

    Code:
    Dec 16 06:04:08 servernamel postfix/cleanup[54941]: fatal: trace: remove 6A65B3DE8523 log: Permission denied
    Dec 16 06:04:10 servernamel postfix/cleanup[59084]: fatal: trace: remove 6D8923DE8523 log: Permission denied
    Dec 16 06:05:02 servernamel postfix/qmgr[40153]: fatal: scan_dir_push: open directory deferred/1: Permission denied
    Dec 16 06:05:10 servernamel postfix/cleanup[54693]: fatal: trace: remove 7508E3DE8523 log: Permission denied
     
    Last edited: Dec 23, 2010

Share This Page