messed up my open_basedir

Discussion in 'Installation/Configuration' started by jimmie, Mar 3, 2013.

  1. jimmie

    jimmie New Member

    i put :etc in open_basedir in ispconfig3 web options andnow i cant get back in
    nothing works
    floorz-n-more.com
    ip address
    lan address

    putty works
    ftp works
    please help!
     
  2. jimmie

    jimmie New Member

    bump to top
     
  3. jimmie

    jimmie New Member

    really need some help here please!
    installed ubuntu 12.10 ispconfig 3 updated to recent version
    i was reading a solution to a php warning and entered :etc on the end of the server config>options>web php open_basedir and now i cant get back into control panel or any websites
    really need help
     
    Last edited: Mar 3, 2013
  4. jimmie

    jimmie New Member

    help

    56 views and no one has a solution?
     
  5. jimmie

    jimmie New Member

    still needing help here

    still needing help here
     
  6. grandslamjmh

    grandslamjmh New Member

    What web option was it that you added it to?
     
  7. jimmie

    jimmie New Member

    php open_basedir
     
  8. grandslamjmh

    grandslamjmh New Member

    and you cant putty into your site to re-edit that php.ini file where you added the :etc for php open_basedir
     
  9. jimmie

    jimmie New Member

    i can putty but open base is controlled by ispconfig. i looked at all instances of php.ini. and they are all commented out.
     
  10. jimmie

    jimmie New Member

    thank you for responding by the way
     
  11. grandslamjmh

    grandslamjmh New Member

    where at do you see open base in ispconfig?
     
  12. jimmie

    jimmie New Member

    system> server config> web> Options> php open_basedir
    i cannot access it anymore
     
  13. grandslamjmh

    grandslamjmh New Member

    so find this in your /etc/php.ini
    if it commented out un comment it and add
    If you were going to put that command in PHP.ini i would probably specify what [website_path] and [website_domain] are because only the ISPConfig web interface knows the true path.

    see if that fixes it, if not then we would have to try something else.
     
    Last edited: Mar 3, 2013
  14. jimmie

    jimmie New Member

    do you mean /etc/php5/apache2/php.ini
     
  15. jimmie

    jimmie New Member

  16. grandslamjmh

    grandslamjmh New Member

    is that the line that was in the Apache php.ini path field?
     
  17. jimmie

    jimmie New Member

    no there is no /etc/php.ini
    there are a few php.ini in /etc/php5
     
  18. grandslamjmh

    grandslamjmh New Member

    check in each php.ini to see if one of them are using the open_basedir
     
  19. jimmie

    jimmie New Member

    ok i did that through out the day today: what i did was uncomment each 1 and added none.
    could not exact string used in ispconfig
     
  20. grandslamjmh

    grandslamjmh New Member

Share This Page