messed up my ISPC3 installation

Discussion in 'Installation/Configuration' started by brandoni, Apr 30, 2009.

  1. brandoni

    brandoni New Member

    I've been working on my new system for a couple of weeks now and it seemed almost ready to go into production, until... I dropped squirrelmail and roundcube in favor of the egroupware package. After this the ISPConfig control panel wouldn't load right anymore- the page only displayed the title but no content.

    For whatever reason I thought it would be a good idea to change the ispconfig user password in mysql... well now nothing works :eek: The first thing I need to work on now is IMAP.

    rather that reinstalling again, i want to understand how to fix it. I tried putting the new password into every affected file in both encrypted form and plain text (which way is correct anyways?) but still get this error:

    I can log into mysql using this account and password. I've even tried giving this mysql account complete access to everything.

    the files I changed were:

    I would be so grateful for some help or a hint :D
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The passord is stored in plaintext in these files.
  3. brandoni

    brandoni New Member

    ahh, thank you. the password just looked cryptic :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, it is based on a random value that is additionally hashed with md5 to generate a cleartext password containing chars and numbers.

Share This Page