Messages stay in Mailbox

Discussion in 'Installation/Configuration' started by Numerizen, Dec 12, 2007.

  1. Numerizen

    Numerizen Member

    Hello all,

    I'm almost done with the setup of my ISPConfig server on a VPS.

    I want to say that this forum has been of great help. The signal to noise ratio is unusually high, and it's really a pleasure to read so much useful posts. I couldn't have managed to go that far without it.

    So far, ISPConfig seems to be what I needed, and I want to configure it entirely.

    Everything works except the following :

    - the server seems to be a little slow. The VPS is'nt really big but no process seems to eat the resources, the memory is almost entirely free, etc. Any hint to speed up things would be greatly appreciated.

    - I only created one user so far (a customer), and everything is fine, except for the default FTP directory (/var/www/web1/user/web1_vb/web/) which is not the same as the web published directory (/var/www/web1/web/). Perhaps I messed up something during the tests. Pretty likely in fact, but I would appreciate some help to straight it up. Or perhaps I don't understand the logic of the soft in this matter.

    - Last but not least, I can send mails to my users and the messages indeed go into the Mailbox directory : /var/www/web1/user/web1_vb/Maildir/new. But I cannot manage to retrieve the message with my mail client.
    Authentication is OK, as says the log :

    Dec 12 17:22:40 vds69235 ipop3d[12419]: pop3 service init from xxxxxxxx
    Dec 12 17:22:45 vds69235 ipop3d[12419]: Auth user=web1_vb host=ACaen-152-1-82-252.w83-115.abo.wanadoo.fr [xxxxxxxxx] nmsgs=0/0
    Dec 12 17:22:45 vds69235 ipop3d[12419]: Logout user=web1_vb host=ACaen-152-1-82-252.w83-115.abo.wanadoo.fr [xxxxxxx] nmsgs=0 ndele=0

    The client seems fine to : no password rejection, no timeout. But no message either.

    This last issue is critical as my server is supposed to go to production yesterday :eek: .

    Hope I didn't torture english too much : this is not my mother language. Sorry if I did.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    VMWare virtual machines are reletively slow compared to e.g. xen, opebvz or a real server. To speed this up, you can try to install the vmware tools.

    You use maildir deliver with a pop3 daemon that does not support maildir. You will have to install courier or dovecot as pop3 daemon.
     
  3. Numerizen

    Numerizen Member

    Thank you very much for your reply.

    My server is a VDS (virtual dedicated server) inside a linux-vserver. It hasn't anything to do with VMWare. I made a typo in my first message. By the way, only the http traffic seems to be slow : mail and FTP feels OK. I installed mod_deflate and commented the lines about DNS resolution in apache2.conf and it did enhance the speed, but not enough for my taste.

    I've checked the Administrator box under my user profile, but it didn't do any good at first. I restarted the server but no luck. And I was surprised to see a few hours later that all of a sudden, my FTP client was directed to the good directory. I didn't really understood what happened. May be some cron job did something in the meantime ?

    Good news for me is my main problem is solved. I installed Dovecot and after a little trouble removing the old pop3 stuff, it worked like a charm. I'll try soon to setup the 'real mail user account name' feature with the howto.

    The only problem left is this : my mail client asks for a confirmation concerning certificates once per session. I can live with it, but I must setup a lower periodicity for my future users. It's a warning because the certificate's domain name is not the same as the mail server's. Any hint would be appreciated but I'll of course do a search on the forum.

    Again, thanks a lot for your advice. Have a nice day.
     
    Last edited: Dec 14, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    You can recreate the certificate with the right hostname as follows:

    Code:
    mkdir /etc/postfix/ssl
    cd /etc/postfix/ssl/
    openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024
    
    chmod 600 smtpd.key
    openssl req -new -key smtpd.key -out smtpd.csr
    
    openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt
    
    openssl rsa -in smtpd.key -out smtpd.key.unencrypted
    
    mv -f smtpd.key.unencrypted smtpd.key
    openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650
     
  5. Numerizen

    Numerizen Member

    Ok

    Sorry for my late reply but I had many things to do these days.

    I tried the manipulations you indicated, but the problem remains. I guess it's something about the main domain name, which is vdsxxxx.nfrance.com - a subdomain in my ISP's domain, which happens to be the hostname of the VDS - and the domain name of the mail accounts - numerizen.com.

    I have to investigate.

    Thank you again, for your replies.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Find out what your hostname is by looking up the reverse record:
    Code:
    dig -x 1.2.3.4
    Replace 1.2.3.4 with your IP address.
    Then use this hostname to create the SSL certificate.
     
  7. Numerizen

    Numerizen Member

    Something clearly escapes me.

    After checking the main domain the way you indicated, it appears it was correct in the first place : vdsxxxxx.nfrance.com is the hostname of the machine.

    I'll host a few domain names on it, each one with its own mail accounts. For example, "numerizen.com". More domain names will come later.

    For each of this domains, the mismatch will happen, and I don't see a way to set the whole thing up to prevent it.

    The question sums up as this : how do you setup SSL with multiple domain names on a virtual hosting solution, where the domains used don't match the hosting machine's name ?

    Hope I made my problem clear, but not sure.
     
    Last edited: Dec 30, 2007
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    On a hosting machine with more then one domain, you use the hostname of the machine to connect to postfix. Thats the normal way it works on every hosting server. You never have a dedicated ssl cert for every virtual domain.
     
  9. Numerizen

    Numerizen Member

    That's what I guessed from the different tutorials I read here and there.

    But then, how do I make the thunderbird message disappear (same one under 'Mail' and under any mail client I think) ?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    First, you need a officially signed ssl certificate for the hostname of your server and then you must use this hostname as smtp and pop3 server name in thunderbird.
     
  11. Numerizen

    Numerizen Member

    Thank you for your answer.

    Does this mean there is no way to setup a SSL enabled POP3 and IMAP server in a virtual environment having some consistence between the hosted domains and the name of the server ?

    I suppose the SSL certificate has to be paid, too. It's not a problem by itself, but what bothers me is paying for a semi-elegant solution, where my customers will have to setup a mail server with a domain name which has nothing to do with their business.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    No. If you want to get consistent mail servers, you will have to run e.g. a separate virtual machine with a complete mail server setup for each domain.
     
  13. Numerizen

    Numerizen Member

    OK, now I think I understand the whole thing.

    So I'll stick with the half satisfying solution for now, or perhaps give up the SSL stack.

    Thank's a lot for this precious information.

    Have a nice day, and a nice year by the way.
     

Share This Page