Messages not analyzed by SA on Postfix with Amavis

Discussion in 'Server Operation' started by asgozzi, Aug 16, 2007.

  1. asgozzi

    asgozzi New Member

    Hi.
    I recently set up a debian etch mail server running Postfix with virtual users in MySQL tables.
    I was able to get Amavis+ClamAV to work (X-Virus-Scanned: by amavisd-new-2.4.2 (20060627) (Debian) at XXX.net) but it seems that spamassassin is never called when a message is received.

    Since I wouldn't know exactly which conf files I should post let me know and I'll do it ASAP.

    Andrea
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please restart amavisd and take a look at /var/log/mail.log. When amavisd restarts, it logs all modules it loads. SpamAssassin should be listed there as well.
     
  3. asgozzi

    asgozzi New Member

    I did what you suggested and apparently amavis is able to load SA:
    Code:
    Aug 16 19:49:38 bnix amavis[12719]: Module Mail::SpamAssassin  3.002000
    unfortunately the spam messages remain unmarked and no headers are added.this is my amavis conf relative to headers & pass/reject rules:

    Code:
    $sa_spam_subject_tag = '***SPAM*** ';
    $sa_tag_level_deflt  = 3.0;
    $sa_tag2_level_deflt = 4.0;
    $sa_kill_level_deflt = 5.0;
    $sa_dsn_cutoff_level = 10;
    
    $final_virus_destiny = D_DISCARD;
    $final_banned_destiny = D_REJECT;
    $final_spam_destiny = D_PASS;
    $final_bad_header_destiny = D_PASS;
    
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You could set $sa_tag_level_deflt to 0.0 for testing purposes and then take a look at the headers of the emails to see if SpamAssassin added the tests to it that scored points.
     
  5. asgozzi

    asgozzi New Member

    so now apparently Amavis correctly tags the messages as spam:

    Code:
    Aug 18 22:17:35 bnix amavis[10877]: (10877-06) Passed SPAM, [66.49.175.101] [66.95.179.33] <[email protected]> -> <[email protected]>, quarantine: spam-mNi8rj1U9lXs.gz, Message-ID: <[email protected]>, mail_id: mNi8rj1U9lXs, Hits: 8.349, queued_as: 87C5817A1, 7494 ms
    Aug 18 22:17:35 bnix postfix/smtp[11625]: A81B715AB: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=8.7, delays=1.1/0.06/0.03/7.5, dsn=2.6.0, status=sent (250 2.6.0 Ok, id=10877-06, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 87C5817A1)
    but still no headers or '[SPAM]' tag are not added to the message.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mail/spamassassin/local.cf?
     
  7. asgozzi

    asgozzi New Member

    never mind I was able to fix it
     

Share This Page