memory error

Discussion in 'General' started by planet_fox, Jan 14, 2007.

Thread Status:
Not open for further replies.
  1. planet_fox

    planet_fox Member

    I Have the Problem, I become of some sites this error code

    Code:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 11520 bytes) 
    How Can I do ? When I do in php.ini the moemory from 8MB to 20MB . Is no change later.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You must restart Apache as well.
     
  3. planet_fox

    planet_fox Member

    Í have do change in php.ini and restart apache . No change when i see in info.php .
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which php.ini did you change?
     
  5. planet_fox

    planet_fox Member

    /etc/php4/cgi/php.ini
    /etc/php4/cli/php.ini

    /etc/php4/apache2/php.ini
     
  6. falko

    falko Super Moderator ISPConfig Developer

    The info.php shows which php.ini PHP is using. Did you modify that one and restart Apache?
     
  7. planet_fox

    planet_fox Member

    Did you modify that one and restart Apache? yes .

    I use suphp is this the Problem ?
     
  8. falko

    falko Super Moderator ISPConfig Developer

    It's possible. Have you tried to disable it?

    OR do you use the Apache Directives field in ISPConfig and have the memory limit set there? Or in an .htaccess file?
    What's in your Vhosts_ispconfig.conf?
     
  9. planet_fox

    planet_fox Member

    vhost

    Code:
    <VirtualHost 22.298.5.226:80>
    SuexecUserGroup web96_ftp web96
    ServerName www.lol.de:80
    ServerAdmin [email protected]
    DocumentRoot /home/ww/web96/web
    ServerAlias lol.de
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 $
    ScriptAlias  /cgi-bin/ /home/ww/web96/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /home/times/ww/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    suPHP_Engine on
    suPHP_UserGroup web96_ftp web96
    AddHandler x-httpd-php .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-php
    Alias /error/ "/home/ww/web96/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /home/ww/web96/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /home/ww/web96/user/$1/web/$3
    </VirtualHost>
    
    
    I have no
    No htaccess or i have in Apache directive set memory limit
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Can you post the link to your info.php?
     
  11. planet_fox

    planet_fox Member

    I have upload to server and become the error 500 . I can only info.php over a joomla site become. I send you a screenshout, is this ok ?.
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Then something weird is going on on your server. What's in Apache's error log?

    Please post the link.
     
  13. planet_fox

    planet_fox Member

  14. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    cd /etc/php4/cgi/
    grep -R memory_limit *
    ?
     
  15. planet_fox

    planet_fox Member

    Code:
    host:/etc/php4/cgi# grep -R memory_limit *
    php.ini:memory_limit = 22M      ; Maximum amount of memory a script may consume                              (8MB)
    php.ini.dpkg-old:memory_limit = 8M      ; Maximum amount of memory a script may                              consume (8MB)
    
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Can you delete php.ini.dpkg-old or move it somewhere else and restart Apache?
     
  17. planet_fox

    planet_fox Member

    yes I have do, no efekt
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Ok, what's the output of
    Code:
    cd /
    grep -R memory_limit *
    ?
     
  19. planet_fox

    planet_fox Member

    hm

    lots of files is to big I can`t post here Some files says

    Code:
    Please set the option 'memory_limit' in your php.ini to a minimum of 16MB
    or

    Code:
    backup_live/compl/2_12_06/www/www.myhost.de/web/coppermine/docs/index.htm:<li><strong>memory_limit</strong> - 8MB is the default size.</li>
    
    :confused:
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Then run
    Code:
    cd /
    grep -R memory_limit * | more
    instead to browse the results.
     
Thread Status:
Not open for further replies.

Share This Page